Failed to compile js with debug enabled on SPARC

RESOLVED DUPLICATE of bug 596338

Status

()

RESOLVED DUPLICATE of bug 596338
8 years ago
8 years ago

People

(Reporter: ginnchen+exoracle, Assigned: ginnchen+exoracle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
The problem is js::JMCheckLogging() symbol not found.
The reason is Logging.cpp is not compiled on SPARC.

To fix it, we can add Logging.cpp to Makefile.in or undef JS_METHODJIT_SPEW in Logging.h.

I think to add Logging.cpp is simpler.
(Assignee)

Comment 1

8 years ago
Created attachment 496763 [details] [diff] [review]
patch
Assignee: general → ginn.chen
Status: NEW → ASSIGNED
Attachment #496763 - Flags: review?(sayrer)
(Assignee)

Comment 2

8 years ago
Comment on attachment 496763 [details] [diff] [review]
patch

I forgot I've already solved this bug with another approach.
Bug 596338.
Attachment #496763 - Flags: review?(sayrer)
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596338
You need to log in before you can comment on or make changes to this bug.