Closed Bug 618290 Opened 9 years ago Closed 9 years ago

Can't connect to sync server

Categories

(Firefox for Android Graveyard :: General, defect, major)

ARM
All
defect
Not set
major

Tracking

(fennec2.0+)

VERIFIED WORKSFORME
Tracking Status
fennec 2.0+ ---

People

(Reporter: anamaria.moldovan, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.15) Gecko/20101026 Firefox/3.5.15
Build Identifier: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre Fennec/4.0b3pre

"Failed to connect to the server" error while trying to connect to the Sync Server.

Devices: Nokia N900 (Maemo GTK), Motorola Droid 2 (Android 2.2), HTC Desire (Android 2.1)

Reproducible: Always

Steps to Reproduce:
1. Open Fennec > Preferences
2. select Sync:yes if disabled
3. select connect
4. select "I'm not near my computer" 
5. Enter in your username or email address, password, and Sync Key
6. pan down and click connect

Actual Results:  
"Failed to connect to the server" error. (Please see the attached photo)

Also if I click Connect and go back to the Account field, "Use custom server" is checked.


Expected Results:  
The device should connect to the Sync Server.
Attached image Sync error
OS: Windows 7 → All
Hardware: x86 → ARM
I have made a mistake regarding the build ID.

This issue is reproducing on Build ID: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b8pre) Gecko/20101210 Firefox/4.0b8pre Fennec/4.0b3pre

I am sorry about it!
Can you connect with a brand new account?
tracking-fennec: --- → ?
Duplicate of this bug: 618340
Does this work after a restart?  The log looks like there were DNS problems with auth.services.mozilla.com (NS_ERROR_UNKNOWN_HOST) so the node lookup was failing.

Can anyone reproduce this currently?
(In reply to comment #6)
> Does this work after a restart?  The log looks like there were DNS problems
> with auth.services.mozilla.com (NS_ERROR_UNKNOWN_HOST) so the node lookup was
> failing.
> 
> Can anyone reproduce this currently?

I've created a new sync account and tried to sync my device with desktop using this account. I get the same results as the ones described by Anna.
After restart, sync fields are empty. I need to re-enter data.

Environment:

Desktop Build ID: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101212 Firefox/4.0b8pre
Device Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre)Gecko/20101212 Firefox/4.0b8pre Fennec /4.0b3pre 
Device: HTC Desire A8181
I think that the sync team had some network issues that have been resolved.  this is WFM now.
Status: NEW → RESOLVED
tracking-fennec: ? → 2.0+
Closed: 9 years ago
Flags: in-litmus?
Resolution: --- → WORKSFORME
Verified worksforme, using the latest nightly and Mobile Firefox2.0b3.
Status: RESOLVED → VERIFIED
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.