addons disabled, updating does not work

RESOLVED DUPLICATE of bug 499247

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 499247
7 years ago
6 years ago

People

(Reporter: kathrin, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

After updating Firefox to the newest versions, all my addons are disabled (like adblock, noscript etc.). They show up fine in the addon menu, no hint as to why they don't work. If I want to update or reinstall, I get the following error:

(German:)
Fehler

Firefox konnte das Add-on von folgender Adresse nicht installieren:

https://addons.mozilla.org/firefox/downloads/latest/1865/addon-1865-latest.xpi?src=search

Grund: Bei der Installation ist ein unbekannter Fehler aufgetreten.
Schauen Sie in der Fehlerkonsole für weitere Informationen nach.
-203

In the console I find different errors, like Mozilla.Expander is undefined, method.apply is not a function.

I cannot browse like this with an unfiltered web, please help fast!

Reproducible: Always

Steps to Reproduce:
1.update to new version
2.all addons are still there but do not work
3.installing / updating them creates the listed error
Actual Results:  
(German:)
Fehler

Firefox konnte das Add-on von folgender Adresse nicht installieren:

https://addons.mozilla.org/firefox/downloads/latest/1865/addon-1865-latest.xpi?src=search

Grund: Bei der Installation ist ein unbekannter Fehler aufgetreten.
Schauen Sie in der Fehlerkonsole für weitere Informationen nach.
-203

Expected Results:  
well i kinda expected that all my addons would still work. or at least show an error message why they don't. and of course I'd expect the updates / installs to work as well.
http://support.mozilla.com is the correct address if you need help.
http://support.mozilla.com/de/kb/Unbekannter%20Fehler%20-203%20bei%20der%20Installation%20von%20Add-ons

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 2

6 years ago
Thanks for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499247
You need to log in before you can comment on or make changes to this bug.