If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

At least once a day running the spellcheck on an outgoing email, causes freeze and losing post.

RESOLVED INCOMPLETE

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED INCOMPLETE
7 years ago
7 years ago

People

(Reporter: jroi12, Unassigned)

Tracking

({dataloss, hang, stackwanted})

x86
Windows XP
dataloss, hang, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-05-01][needs stacktrace][regression?])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)
Build Identifier: 3.6.13  or   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)

I run spell check just before sending.  At least once a day teh checked word will gray out and the hour glass will hang.  There is no other solution than to close program and lose the post I have written.

Reproducible: Sometimes

Steps to Reproduce:
1. I have not discovered a pattern.  It seems to happen randomly.  
2.
3.
Actual Results:  
Program stays with hour glass until I shut it down.  I can work with other programs but TB and all related TB windows  are frozen


Check or correct the word and move to next.  This has happened daily since 3.1 installed.   I told my husband NOT to upgrade and he has not hadd this problem,

I can't answr these technical quesitons.
(Reporter)

Comment 1

7 years ago
I cannot continue to use TB if this continues.  I am trying to remember to copy emails before running spellcheck.
Does starting Thunderbird in -safe-mode as described at http://support.mozillamessaging.com/en-US/kb/Safe+Mode helps ?
Keywords: hang
(Reporter)

Comment 3

7 years ago
Since i never know when it will happen I would have to use it in safe mode always.  Not acceptable.  Is there a way to revert to an older version?  I had no problem before the upgrade.  (I lost another long post I had written last night when i went to send it.)

Comment 4

7 years ago
We've noticed this issue with a couple of our users as well. I agree that it seemed to have started around the time 3.1 came out and the only way to continue is to close Tbird and lose the email. 
We believe it may have something to do with having the "Check spelling before sending" option checked as well as clicking the Spellcheck icon before sending. A fix would be great...we have a couple users that experience this issue weekly and sometimes daily. Seems to be very random, however.
what dictionary are you using?
can you get a stacktrace?  (attach text file to this bug)
 https://developer.mozilla.org/En/How_to_get_a_stacktrace_with_windbg
 https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report#Alternative_ways_to_get_a_stacktrace

xref Bug 633920 - Thunderbird hangs checking the spelling of "milennium"

iirc, version 3.1 picked up a new version of hunspell.
version 3.1.8/3.1.9 got a minor update, hunspell 1.2.12. I doubt if fixes much.
version 3.3 (still in alpha) does not have a new version of hunspell
Keywords: dataloss, stackwanted
Summary: At least once a day running the spellcheck on an outgoing email, causes freeze and only solution is closing TB and losing post. → At least once a day running the spellcheck on an outgoing email, causes freeze and losing post.
Version: unspecified → 3.1
Whiteboard: [closeme 2011-05-01][needs stacktrace][regression?]
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.