XML error in mail windows (fr locale)

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: stephane.gregoire, Assigned: bugzilla.fr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101211 Firefox/4.0b8pre SeaMonkey/2.1b2pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101211 Firefox/4.0b8pre SeaMonkey/2.1b2pre

Erreur d'analyse XML : mal formé
Emplacement : chrome://messenger/content/msgAccountCentral.xul
Numéro de ligne 125, Colonne 24 :          <description>&feedsSectionHdr.label;</description>
-----------------------^

Reproducible: Always

Steps to Reproduce:
1.getting http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-trunk-l10n/seamonkey-2.1b2pre.fr.linux-i686.tar.bz2
2.Open mail window

Actual Results:  
Erreur d'analyse XML : mal formé
Emplacement : chrome://messenger/content/msgAccountCentral.xul
Numéro de ligne 125, Colonne 24 :          <description>&feedsSectionHdr.label;</description>
-----------------------^

Expected Results:  
Normal page.
(Reporter)

Updated

8 years ago
Severity: normal → major
Keywords: intl
Version: unspecified → Trunk
Don't see this with Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101211 Firefox/4.0b8pre SeaMonkey/2.1b2pre, so related to the locale or the OS.

Stéphane, do you have a regression range when this started?
Severity: major → normal
Version: Trunk → unspecified
(Reporter)

Comment 2

8 years ago
Hi,
What is a "regression range"?
(Reporter)

Comment 3

8 years ago
Also appeared in safe mode.

/usr/local/seamonkey/seamonkey -safe-mode

I don't understand why you marked the version as unspecified...

I also think that's a locale bug but where can I post this bug?
(In reply to comment #2)
Regression range means you have a build that still works and a newer build that fails. Is this the first trunk nightly you see this or has it occurred earlier?

(In reply to comment #3)
> I don't understand why you marked the version as unspecified...
Sorry, that wasn't intended, changed it back.

> I also think that's a locale bug but where can I post this bug?
This is the right place, just speculated about the reasons.
Severity: normal → major
Version: unspecified → Trunk
Summary: XML error in mail windows → XML error in mail windows (fr locale)
If this doesn't happen with en-US, it's a l10n bug. Not changing Product/Component yet because someone needs to verify. Serge, can you?

Interestingly, fr/suite/ seems to be the only combination where a &#...; entity is used; it's even different for fr/mail/ (why?):
http://mxr.mozilla.org/l10n-central/search?string=feedsSectionHdr&tree=l10n-central

Probable problem source:
http://hg.mozilla.org/l10n-central/fr/rev/aa6fcb73f567

Comment 6

8 years ago
Cedric, does that belong into L10n:fr instead?

Comment 7

8 years ago
Robert, yes, this is a French localization known bug: we didn't update the help files yet.Robert, yes, this is a French localization known bug only: we didn't update the help files yet.
Assignee: nobody → bugzilla.fr
Status: UNCONFIRMED → NEW
Component: MailNews: General → fr / French
Ever confirmed: true
Product: SeaMonkey → Mozilla Localizations
QA Contact: mail → benoit.leseul
Version: Trunk → unspecified

Updated

8 years ago
Severity: major → normal
Keywords: intl
Priority: -- → P3
(Reporter)

Comment 8

8 years ago
Hi,

I have another error today with Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101226 Firefox/4.0b9pre SeaMonkey/2.1b2pre :

Erreur d'analyse XML : mal formé
Emplacement : jar:file:///usr/local/seamonkey/chrome/messenger.jar!/content/messenger/start.xhtml
Numéro de ligne 52, Colonne 10 :  <title>&startpage.title;</title>
---------^

I have also the other one.

This one is gave by seamonkey when opening by example mozilla.dev.apps.seamonkey and when not opening a message.
(Reporter)

Comment 9

8 years ago
How can I help to translate those strings?

Comment 10

8 years ago
I see this too.

Cédric: per comment #5 this has nothing to do with the help content, it's when we switched from HTML entities to numeric entities to fix the compare-locale warnings on the dashboard. 

Can't we just use regular UTF-8 like in the other files? If we can't, there is a bigger problem here and we should ask Pike how to encode 'special' characters like NBSP in entities to be included in HTML files.
(Reporter)

Comment 11

8 years ago
I sometime for web applications in ZK1 have to replace &nbsp; by &#160; !

Comment 13

8 years ago
I just browse the files, and we may also have problems with start.dtd too:
http://hg.mozilla.org/l10n-central/fr/file/ed7c4c235c58/suite/chrome/mailnews/start.dtd

Comment 14

8 years ago
All issues fixed as of Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110210 Firefox/4.0b12pre SeaMonkey/2.1b3pre thanks to Frédéric and Benoît.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 15

8 years ago
Actually there was still an error in the "Account Central" but it should be fixed in the next nightly. I'll will mark this as verified when I'm sure it worked.

FWIW, NBSP wasn't a problem at all, all of this was caused by the & character which has a special meaning in XML (&#x0026;). Pike helped me to sort it out during the Fosdem.

Comment 16

8 years ago
Verified with today's nightly (20110211). Sorry for the delay.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.