The td, div or span containers don't respect the width values of inline SVG

RESOLVED WORKSFORME

Status

()

Core
SVG
--
major
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Wael Elbanna, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

The width of the container (td, div or span) of inline SVG elements doesn't reflect the width attribute of the SVG as follows:

<svg version="1.1" width="265.58749" height="437.92499" viewBox="0 0 265.58749 437.92499" style="vertical-align: -172.964pt;" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">...



Reproducible: Always

Actual Results:  
The computed td width="154.067px"
The actual SVG width="265.58749px"

Expected Results:  
The td width should be expanded to fit the SVG width + padding.

The td width less than the SVG width.
(Reporter)

Updated

7 years ago
Severity: normal → major
Summary: The td, div or span containers doesn't respect the width values of inline SVG → The td, div or span containers don't respect the width values of inline SVG
(Reporter)

Updated

7 years ago
See Also: → bug 401775
(Reporter)

Updated

7 years ago
Depends on: 401775
(Reporter)

Updated

7 years ago
See Also: bug 401775
(Reporter)

Comment 1

7 years ago
Created attachment 497139 [details]
HTML with table containing inline SVG
(Reporter)

Updated

7 years ago
(Reporter)

Updated

7 years ago
Attachment #497139 - Attachment mime type: text/html → application/xhtml+xml
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Keywords: testcase
(Reporter)

Updated

7 years ago
Severity: major → critical
Component: Layout → Extension Compatibility
Product: Core → Firefox
Version: Trunk → 3.6 Branch
Severity: critical → major
Component: Extension Compatibility → Layout
Product: Firefox → Core
Version: 3.6 Branch → Trunk
Is the SVG frame not reporting a correct min-width and pref-width here?
Component: Layout → SVG
QA Contact: layout → general
In particular, looks like nsSVGOuterSVGFrame::GetMinWidth always returns 0; that seems wrong.  Shouldn't it return the same thing as GetPrefWidth, like nsImageFrame does?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Seems OK now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.