Switch to tab causing non-switching to non-tab

VERIFIED DUPLICATE of bug 558626

Status

()

Firefox
Address Bar
VERIFIED DUPLICATE of bug 558626
8 years ago
7 years ago

People

(Reporter: Michael, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [switch-to-tab])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101210 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101210 Firefox/4.0b8pre

I want to see my Hulu queue.  So I type "q" in the address bar, which brings up Hulu Queue.  Great, except it doesn't bring up the page, it brings up "switch to tab".  Not only don't I want to switch to an existing tab, but Hulu isn't even open on an existing tab, so there is nothing to switch to.  It does not bring up a link to the actual site either.  If I click on the switch to tab link, it switches to nothing at all.

Reproducible: Always

Steps to Reproduce:
1.  Type q.  Hulu Queue comes up, but only as switch to tab.
2.  Hit enter.  Browser switches to nothing.
3.  Manually go to the Hulu Queue.  The page does not enter the list of possible choices when I type q.
Actual Results:  
Switch to tab appears when it shouldn't.  The actual link to the Hulu Queue never appears (although it did until a few days ago.)

Expected Results:  
Hulu queue appears.
Component: General → Location Bar
QA Contact: general → location.bar
could you please give us the list of extensions you have enabled, you can get it from about:support page.
also, if you can reproduce regularly, we would like to have steps from opening hulu, adding stuff to the queue, closing hulu pages and then searching. We need to reproduce the bug from scratch to be able to fix it.
(Reporter)

Comment 3

8 years ago
Linky3.0.0 truelinky@gemal.dk
Adblock Plus1.3.2true{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

By the way, searching for and deleting all entries in my history related to Hulu and then going to the Hulu queue page solved the problem.

It would be great to be able to disable switch to tab completely.  It's pretty useless, causes problems, and makes navigation harder.
(Reporter)

Comment 4

8 years ago
To open hulu:
I hit q in the location bar.  It's the first or second entry, because it's the site I go to most often with a q in it.

Adding things to the queue: I hit the + icon on hulu video pages when there's a show that I want to add to teh queue.

Closing pages: I close nearly all pages with command-W.  Sometimes I use the X on the tab though.

Searching: Not sure if you mean the url bar, or something else.  I just type "q" in the url bar, and I get Hulu Queue and another site with a Q in it that I visit frequently.  The Hulu Queue page is usually at the top, because I visit it most often of those pages with a q in them.

Comment 5

7 years ago
I have the same problem
Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

I found a way to always reproduce the bug:
1- Open FF
2- Go to a website, say: www.mozilla.org
3- Switch to private browsing
4- Switch to normal browsing
5- Close the opened tab (www.mozilla.org)
6- Type 'mozi' or whatever to get the suggestion, and we have the problem

All extensions are disabled.

Comment 6

7 years ago
In Beta 10 the above procedure doesn't reproduce the problem anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558626
Whiteboard: [switch-to-tab]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.