message close does not return to mail window

RESOLVED DUPLICATE of bug 508776

Status

Thunderbird
Toolbars and Tabs
RESOLVED DUPLICATE of bug 508776
7 years ago
7 years ago

People

(Reporter: Humphrey P van Polanen Petel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7

when I close a message what is displayed is the right-most tab

Reproducible: Always

Steps to Reproduce:
1.open calendar (for example)
2.select mail tab
3.open message
4.close message

Actual Results:  
after I close an open message what is displayed is the right-most window/tab

Expected Results:  
after I close an open message what should be displayed is the mail window/tab
I'm pretty sure that what you are seeing is what we wanted by design.
Component: General → Toolbars and Tabs
QA Contact: general → toolbars-tabs
(Reporter)

Comment 2

7 years ago
Generally, opening windows follows the lifo-stack philosophy.  Therefore, when I close a message I expect to be returned to where I was before I opened that message. If you designed it to behave differently then you are intentionally going against system-wide established practices and confusing everybody.  That would be exceedingly unlikely and, assuming you are well-intended (as indicated by being part of an open-source project), I conclude that this cannot not be what you "wanted by design" and that therefore this is an oversight and should be rated as a bug.
I believe there are already tab bugs open for this but I haven't looked recently.  What we have now wasn't the final design we wanted.  Message (child) tabs are supposed to open to the right of folder (parent) tabs and when closed, child tabs should return you to parent tabs that opened them.

So I think this is a bug but I believe it's a duplicate of a couple out there already.
Whiteboard: dupme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 508776
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.