Add-on version not updated

RESOLVED INVALID

Status

Firefox for Android Graveyard
General
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: ashah, Unassigned)

Tracking

Fennec 1.1
ARM
Android

Details

(Reporter)

Description

8 years ago
Mozilla/5.0(Android Linux armv7l; rv2.0b8pre)Gecko/20101212 Firefox/4.0b8pre Fennec/4.0b3pre

In the about:config of fennec, Change the extensions.update.url to the following:
https://addons.allizom.org/z/update?reqVersion=%REQ_VERSION%&id=%ITEM_ID%&version=%ITEM_VERSION%&maxAppVersion=%ITEM_MAXAPPVERSION%&status=%ITEM_STATUS%&appID=%APP_ID%&appVersion=%APP_VERSION%&appOS=%APP_OS%&appABI=%APP_ABI%&locale=%APP_LOCALE%&currentAppVersion=%CURRENT_APP_VERSION%

STR:
1. Install an older version of an addon. 
2. Go to the addons manager in fennec and click "update" button
3. It will check for the updates and then it will say "compatibility update has been applied".

Expected result:
The add-on version number should change to whatever the latest version is.

Actual result:
The addon version number stays the same. It does not change even after a compatibility update has been applied.

Updated

8 years ago
Component: Compatibility Tools → API
QA Contact: compatibility → api

Updated

8 years ago
Summary: Addon version not updated → Add-on version not updated

Updated

8 years ago
Assignee: nobody → amckay

Comment 1

8 years ago
Not sure if this is an issue with the update script, but with fennec. What does "a compatibility update has been applied" mean?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Not sure if this is an issue with the update script, but with fennec. What does
> "a compatibility update has been applied" mean?

This means that the addon has been updated from the older version to the newer version, supported by(or compatible to) that build of fennec.
This sounds like a fennec bug?
Assignee: amckay → nobody
Component: API → General
Product: addons.mozilla.org → Fennec
QA Contact: api → general
Version: unspecified → Fennec 1.1
Comparability updates can't contain a version bump, or they are marked as real updates. In compatibility updates, the addon remains exactly the same, but Fennec now knows that it is compatible.

Resolving invalid.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.