Closed Bug 618805 Opened 9 years ago Closed 5 years ago

persdict.dat is not being updated

Categories

(Core :: Spelling checker, defect)

1.9.2 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: harald-rene.flasch, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

When I use "Add to dictionary" menu item the added word does not appear in persdict.dat immediately even the spell checker does not underline it. When exit Firefox and restart it, the added word is being lost.

Even this issue is similar to https://bugzilla.mozilla.org/show_bug.cgi?id=338291 it is another issue but related to that issue.

Reproducible: Always

Steps to Reproduce:
1. use "Add to dictionary" menu item in order to add a custom word (persdict.dat)
2. Close Firefox
3. Start again and you'll see that the custom word which you have added is lost
Actual Results:  
Missing added word(s) in persdict.dat! Sometimes, after a while or when changing between tabs etc. the word "maybe" was added to persdict.dat

Expected Results:  
When using "Add to dictionary" the selected word should be added immediately in persdict.dat

Used a local file called TypoTest.htm to reproduce the behavior:

<html>

<head>
	<title>Test page</title>
</head>

<body>

<textarea cols="80" rows="25">This is typo: Myy namme is Test.
hfr
hfrmobile
HfrSoft</textarea>

</body>

</html>
Component: General → Spelling checker
Product: Firefox → Core
QA Contact: general → spelling-checker
Version: unspecified → 1.9.2 Branch
Sometimes it also may happen that words are removed from persdict.dat file. Maybe when opened more than one tab in FF?
See Also: → 727886
related to bug 345852?
Duplicate of this bug: 727886
The words are added to the dictionary at application exit time.
That might be suboptimal, but there is bug 345852 for it.
Whoever wants to vote for having the dictionary additions be written to the dictionary on disk immediately, should vote on the other bug.

No need to carry this bug around forever.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Wow, it took almost five years for this awareness ...

Thank you for your response anyway, I'll vote for such an option.
You need to log in before you can comment on or make changes to this bug.