crash [@ nsIFrame::InvalidateWithFlags(nsRect const&, unsigned int) ]

VERIFIED DUPLICATE of bug 618832

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 618832
8 years ago
7 years ago

People

(Reporter: johnp, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101213 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101213 Firefox/4.0b8pre

Firefox crashes like this when trying to print from File->Print...
Don’t know if this is a new bug from todays minefield.

Reproducible: Always

Steps to Reproduce:
1. Open a web page
2. Try to print with File->Print...
3. Get a crash
Actual Results:  
Firefox is crashing and nothing prints.

Expected Results:  
The page gets printed and Firefox doesn’t crash.

Signature	nsIFrame::InvalidateWithFlags(nsRect const&, unsigned int)
UUID	4dd8acd5-5b68-44ca-95f0-980af2101213
Time 	2010-12-13 13:15:10.259675
Uptime	39
Last Crash	87 seconds before submission
Install Age	1508 seconds (25.1 minutes) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101213030326
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	AuthenticAMD family 6 model 8 stepping 0
Crash Reason	EXCEPTION_ACCESS_VIOLATION_WRITE
Crash Address	0x2f1
User Comments	
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 0253
AVSDA over [MSAFD Tcpip [TCP/IP]] : 2 : 1 :
AVSDA over [MSAFD Tcpip [UDP/IP]] : 2 : 2 : C:\Programme\Avira\AntiVir Desktop\avsda.dll
MSAFD Tcpip [TCP/IP] : 2 : 1 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [RAW/IP] : 2 : 3 : %SystemRoot%\system32\mswsock.dll
RSVP UDP Service Provider : 6 : 2 : %SystemRoot%\system32\rsvpsp.dll
RSVP TCP Service Provider : 6 : 1 : %SystemRoot%\system32\rsvpsp.dll
MSAFD Tcpip [TCP/IPv6] : 2 : 1 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [UDP/IPv6] : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [RAW/IPv6] : 2 : 3 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip6_{D3FAA67A-26CF-4BD7-8E66-CD2D12C9640E}] SEQPACKET 7 : 2 : 5 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip6_{D3FAA67A-26CF-4BD7-8E66-CD2D12C9640E}] DATAGRAM 7 : 2 : 2 : %SystemRoot%\system32\mswsock.dll
Processor Notes 	WARNING: Json file missing Add-ons
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsIFrame::InvalidateWithFlags 	layout/generic/nsFrame.cpp:4063
1 	xul.dll 	nsIFrame::Invalidate 	layout/generic/nsIFrame.h:1982
2 	xul.dll 	PresShell::DoReflow 	layout/base/nsPresShell.cpp:7734
3 	xul.dll 	PresShell::ProcessReflowCommands 	layout/base/nsPresShell.cpp:7922
4 	xul.dll 	PresShell::FlushPendingNotifications 	layout/base/nsPresShell.cpp:4884
5 	xul.dll 	nsPrintEngine::ReflowPrintObject 	layout/printing/nsPrintEngine.cpp:2035
6 	xul.dll 	nsPrintEngine::ReflowDocList 	layout/printing/nsPrintEngine.cpp:1873
7 	xul.dll 	nsPrintEngine::SetupToPrintContent 	layout/printing/nsPrintEngine.cpp:1682
8 	xul.dll 	nsPrintEngine::DocumentReadyForPrinting 	layout/printing/nsPrintEngine.cpp:1514
9 	xul.dll 	nsPrintEngine::Observe 	layout/printing/nsPrintEngine.cpp:3351
10 	xul.dll 	nsPrintProgress::DoneIniting 	embedding/components/printingui/src/win/nsPrintProgress.cpp:221
11 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
12 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1588
13 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4748
14 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:657
15 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:737
16 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
17 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5029
18 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2177
19 	xul.dll 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:8966
20 	xul.dll 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9311
21 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
22 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:517
23 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:626
24 	nspr4.dll 	PR_AssertCurrentThreadOwnsLock 	nsprpub/pr/src/threads/combined/prulock.c:404
25 	nspr4.dll 	PR_AssertCurrentThreadOwnsLock 	nsprpub/pr/src/threads/combined/prulock.c:404
26 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
27 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
28 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
29 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:192
30 	xul.dll 	xul.dll@0xb1791b 	
31 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:191
32 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3691
33 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:128
34 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
35 	kernel32.dll 	BaseProcessStart
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618832

Updated

8 years ago
Status: RESOLVED → VERIFIED
blocking2.0: ? → ---
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsIFrame::InvalidateWithFlags(nsRect const&, unsigned int) ]
You need to log in before you can comment on or make changes to this bug.