If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Retrying hg clone succeeded, but build job failed anyway

RESOLVED DUPLICATE of bug 618905

Status

Release Engineering
General
RESOLVED DUPLICATE of bug 618905
7 years ago
4 years ago

People

(Reporter: philor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Several mozilla-central build jobs just died, apparently because the step cloning mozilla-central failed at first, tried again, succeeded, but the retry was pointless since the whole job got killed. Excerpted from http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1292278234.1292278961.8402.gz though the others seem the same:

======== BuildStep started ========
update failed
=== Output ===
starting mercurial operation
/opt/local/bin/hg pull --verbose http://hg.mozilla.org/mozilla-central
pulling from http://hg.mozilla.org/mozilla-central
searching for changes
abort: HTTP Error 500: Internal Server Error
elapsedTime=4.724825
update failed, clobbering and trying again
rm -rf /builds/slave/mozilla-central-macosx64/build
elapsedTime=125.369360
now retrying VC operation
/opt/local/bin/hg clone --verbose --noupdate http://hg.mozilla.org/mozilla-central /builds/slave/mozilla-central-macosx64/build
requesting all changes
adding changesets
adding manifests
adding file changes
added 59163 changesets with 279588 changes to 70172 files (+27 heads)
elapsedTime=469.189275
/opt/local/bin/hg identify --num --branch
program finished with exit code 0
elapsedTime=0.739612
/opt/local/bin/hg paths default
program finished with exit code 0
elapsedTime=0.265990
/opt/local/bin/hg update --clean --repository /builds/slave/mozilla-central-macosx64/build --rev cef32fff6f24f3f0e47a21b7698039dbc7d8f23a
49018 files updated, 0 files merged, 0 files removed, 0 files unresolved
elapsedTime=100.576142
/opt/local/bin/hg identify --id --debug
elapsedTime=2.475544
program finished with exit code 0
=== Output ended ===
======== BuildStep ended ========
======== BuildStep started ========
maybe rebooting slave lost
=== Output ===
=== Output ended ===
======== BuildStep ended ========

The entire build job was retried, that part's fine, but it seems sort of pointless to retry a failed hg step if the whole job is going to fail even if the step succeeds the second time.
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618905
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.