buildbot retries jobs when the mercurial step succeeds

RESOLVED FIXED

Status

P5
normal
RESOLVED FIXED
8 years ago
7 months ago

People

(Reporter: aki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/3064] [automation][cleanup][retry])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 497316 [details]
mercurial step that failed, then succeeded

a) Mercurial step runs
b) Mercurial step fails at first
c) Mercurial step retries (during same step) and succeeds
d) our buildbot retry code detects the error, kills the job, and requeues it.

We should be smarter about this.
Duplicate of this bug: 618904
Did switching to hgtool fix this already? I can't recall seeing this recently.
Component: Release Engineering → Release Engineering: Automation (General)
QA Contact: release → catlee
Whiteboard: [automation][cleanup][retry]
Until we eliminate all Mercurial steps this could still happen. Most things use a RetryingShellCommand for hgtool though, so we shouldn't see this often.
Product: mozilla.org → Release Engineering

Updated

4 years ago
Whiteboard: [automation][cleanup][retry] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/3054] [automation][cleanup][retry]

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/3054] [automation][cleanup][retry] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/3059] [automation][cleanup][retry]

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/3059] [automation][cleanup][retry] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/3064] [automation][cleanup][retry]
Probably not an issue anymore...
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.