Extra space for smart keyword results

RESOLVED FIXED in Firefox 4.0b9

Status

()

defect
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Mardak, Assigned: adw)

Tracking

({regression})

Trunk
Firefox 4.0b9
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Regression from bug 596485 where the extra ellipses are being visibility: hidden, so they take up space but aren't visible. visibility: collapse doesn't seem to help but display: none gets rid of the gap.
Blocks: 596485
No longer depends on: 596485
(Assignee)

Comment 1

9 years ago
Posted patch patchSplinter Review
Yeah, previously the hidden property was set on the ellipsis, which translates to display: none.  This patch uses hidden for keyword searches again.

But actually, the title box's flex is set to 0 for keyword searches, so I don't think the title ellipsis in that case is ever shown.  It's always pushed out of view, since the title is allowed to grow as big as it wants.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Attachment #497700 - Flags: review?(gavin.sharp)
(Assignee)

Updated

9 years ago
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Comment on attachment 497700 [details] [diff] [review]
patch

Mmm, hacky. The _extraBox stuff is sort of a mess.
Attachment #497700 - Flags: review?(gavin.sharp) → review+
blocking2.0: --- → final+
Is this ready to land?
Whiteboard: [has patch][has review]
(Assignee)

Comment 4

8 years ago
Ready to land.
Whiteboard: [has patch][has review] → [can land]
(Assignee)

Comment 5

8 years ago
http://hg.mozilla.org/mozilla-central/rev/042e89e18821
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [can land]
Target Milestone: --- → Firefox 4.0b9
You need to log in before you can comment on or make changes to this bug.