Closed Bug 618977 Opened 9 years ago Closed 9 years ago

Specifying an invalid test-path no longer complains about no tests to run, instead just does nothing

Categories

(Testing :: Mochitest, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mossop, Assigned: jmaher)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

If you give a test-path that doesn't include any tests (f.e. if you typo a test name) then clicking run tests switches to the browser window and then nothing happens. The error console displays:

Error: linkArray is undefined
Source File: chrome://mochikit/content/server.js
Line: 555
simple fix to display an no tests found when specifying a --test-path for browser-chrome.  This fix also will work for mochitest and mochitest-chrome since they use the same functions.
Assignee: nobody → jmaher
Attachment #498754 - Flags: review?
this is passing on try server.
I updated the patch to current trunk and made a minor tweak. Joel, do you want to land this or shall I?
Attachment #498754 - Attachment is obsolete: true
Attachment #533361 - Flags: review+
Attachment #498754 - Flags: review?
I can land this tomorrow morning on m-c, but feel free to land this earlier if you have other patches landing.
http://hg.mozilla.org/mozilla-central/rev/a365ca6c2379
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I just had this very issue (linkArray is undefined) because I hadn't updated the Makefile.in and ran make -C dom/tests/mochitest/chrome to make sure the test file was copied in my objdir. My copy of m-c is fresh from a couple days ago. Should I file a new bug or reopen this one?
Component: BrowserTest → Mochitest
You need to log in before you can comment on or make changes to this bug.