Unicode Telugu language characters are not rendered properly

RESOLVED WORKSFORME

Status

()

--
trivial
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: svln_jntu, Unassigned)

Tracking

3.6 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20101005 Fedora/3.6.10-1.fc14 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20101005 Fedora/3.6.10-1.fc14 Firefox/3.6.10

The fonts provided by this site are installed first. Then point to the site (www.eenadu.net). It shows a dash (-) character which should not be there. For example, Google Chrome shows it perfectly.


Reproducible: Always

Steps to Reproduce:
1.Go to www.eenadu.net (a Telugu news paper) site and install fonts from that site.
2.open the main page (http://www.eenadu.net). It shows some dashes at the main headings in the centre, which should not appear.
3.Check the same site with Google chrome, and you will note the difference.
Actual Results:  
Page is not rendered according to the content in Telugu- an Indian language which is used by about 80 million people.

Expected Results:  
dashes that are wrongly shown, which should be removed.

compare with Google chrome and the result should match that of Google chrome.

Comment 1

8 years ago
I'm not seeing any difference at all, but I can't read Telugu at all. It would be better if you showed an example what is wrong.

I tested Firefox 3.6.13, 4.0b8pre and Chrome 8.0.552.215 on a standard en_US Windows XP (no additional international font support installed). Note that I did not install any additional font as suggested by http://www.eenadu.net/fonthelp.htm which might actually be wrong advice (it still mentions Netscape 4.0, so you can see how old that one is), back from the days when Unicode wasn't used everywhere. In general, you should not install any additional fonts at all, the ones from the OS should be enough. Of course, if you use a language that is not supported by your OS, that's different.

Comment 2

8 years ago
The problem is in Linux versions. Eenadu font is older truetype font. The dashes disappear sometimes in Firefox 4.0.
OS: All → Linux

Updated

8 years ago
Version: unspecified → 3.6 Branch

Comment 3

5 years ago
Hi,

eenadu.net uses proprietary fonts so this problem. There is a add-on available for this https://addons.mozilla.org/en-US/firefox/addon/padma/

Though, with the latest version of firefox we wont need any add-on to be installed, it is rendering fine now.

I think we can resolve this bug.

Thanks,
Krishna.

Comment 4

5 years ago
(In reply to Krishna Babu K from comment #3)
> Hi,
> 
> eenadu.net uses proprietary fonts so this problem. There is a add-on
> available for this https://addons.mozilla.org/en-US/firefox/addon/padma/
> 
> Though, with the latest version of firefox we wont need any add-on to be
> installed, it is rendering fine now.
> 
> I think we can resolve this bug.
> 
Yes.

Arjuna
> Thanks,
> Krishna.

Updated

5 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.