Cannot load a specific SVG file with file:// protocol, this will generate a memory crash

RESOLVED DUPLICATE of bug 619075

Status

()

Firefox
File Handling
--
critical
RESOLVED DUPLICATE of bug 619075
7 years ago
7 years ago

People

(Reporter: Jerome, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/8.04 (hardy) Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/8.04 (hardy) Firefox/3.6.13

First, this makes the second time I file this bug, so sorry if there is less details than the previous one. I have tried to attach my SVG and ... this generate a new crash (was the subject of this bug-report ...)

I do not have any feedback and command line return, Firefox 3.6.13 and 4beta7 cannot upload a specific SVG file. Please give me a mail address for sending the file. 

Reproducible: Always

Steps to Reproduce:
1.try to upload this SVG file (it seems not to be malformed)
2.file manager is open (nautilus for me), then when displaying the parent directory, firefox-bin needs too much memory (50M -> 400 ++++M)
3.need to kill application
Actual Results:  
buffer cache issue/crash

Expected Results:  
properly load the SVG file
(Reporter)

Comment 1

7 years ago
Please, close this one: duplicated => see #619075
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 619075
Group: core-security
You need to log in before you can comment on or make changes to this bug.