If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when checking NEW messages every 60 minutes

VERIFIED DUPLICATE of bug 58721

Status

MailNews Core
Backend
P3
critical
VERIFIED DUPLICATE of bug 58721
17 years ago
9 years ago

People

(Reporter: Dieter Gaul, Assigned: racham)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001203
BuildID:    2000120308

After I added a new newsserver to my account settings, everything seemed to work
fine. Some time later (maybe around the time when the next check interval
arrived), mozilla started to increase its memory usage until the system
ressources have been exhausted and crashed. Now the same thing happens every
time I try to open the mail window.

Reproducible: Always
Steps to Reproduce:
Just open the mail window...

Actual Results:  mozilla displays the mail window and crashes then

Expected Results:  open the mail window
(Reporter)

Comment 1

17 years ago
Created attachment 20178 [details]
these preferences cause the crash
(Reporter)

Comment 2

17 years ago
Created attachment 20179 [details]
these preferences are working
(Reporter)

Comment 3

17 years ago
Further experimenting with the prefs, I found that the crash is not caused by
adding the second newsserver (sorry for the wrong description...). Instead it
seems to be caused by the check interval for new messages of 60 minutes. After
setting this to 10 minutes the crash did not occur anymore. I hope this helps
you in resolving this bug.

Comment 4

17 years ago
Reporter are you still seeing this in the latest nightlies?
Summary: crash during opening of mail window → Crash when checking NEW messages every 60 minutes
(Reporter)

Comment 5

17 years ago
I tried Build 2000121904 and the crash still occurs.

Comment 6

17 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

17 years ago
This happens in 2000122708 on Linux, as well.  From the network activity on my
hub when I start mailnews, I wonder if it's taking the number of minutes as a
number of milliseconds?

Updated

17 years ago
Keywords: crash

Comment 8

17 years ago
cc'ing racham. This sounds like a dup of the bug Bhuvan recently fixed to use
Int64's in the biff code.
(Assignee)

Comment 9

17 years ago
Reassigning to myself.
Assignee: mscott → racham
(Assignee)

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 10

17 years ago
Fix for this bug went in on March 6th, 2001 (So, please try the latest build out
there..you should be fine). All the updates reporting the problem are prior to
that date.

Marking this as dup of 58721.

Adding Sheela to the cc list.

*** This bug has been marked as a duplicate of 58721 ***
verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.