Fennec UI should not enable Connect unless all fields are entered

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: ashah, Assigned: mfinkle)

Tracking

Trunk
ARM
Android

Details

(Whiteboard: [e0])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Mozilla/5.0(Android; Linux armv7l; rv:2.0b8pre) Gecko/20101214 Firefox/4.0b8pre
Fennec/4.0b3pre

STR:
1. Open Fennec > Preferences
2. Make sure that you are not connectd to Sync.
3. Click on the "Connect" button.
4. Click on "I am not near my computer"
5. In the login screen that is shown, do not enter anything. Click "connect"

Expected Result:
Nothing should happen

Actual Result:
You are taken to the preferences page and the Sync shows "Not Connected. Unknown Error"
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
This is another example of unhelpful error messages.   lets track all this and figure out how to redesign the workflow.
(Reporter)

Updated

8 years ago
Depends on: 619808
Component: General → General
Product: Fennec → Mozilla Services
QA Contact: general → general
Version: Trunk → unspecified
I'm not so sure this is a Sync bug. It seems more like a Fennec UI bug. The Firefox UI ensures that it doesn't call into Weave.Service with obviously bogus inputs (e.g. empty strings). In fact, it disables the buttons for such cases.
Yeah, concur, the UI should prevent this, rather than have us add strings for cases that UI shouldn't allow.
Component: General → General
Product: Mozilla Services → Fennec
QA Contact: general → general
Summary: Incorrect error message shown when nothing entered in sync login → Fennec UI should not enable Connect unless all fields are entered
Version: unspecified → Trunk
Assignee: nobody → mark.finkle
tracking-fennec: ? → 2.0+
Duplicate of this bug: 625638
Priority: -- → P2
Whiteboard: [e0]
Created attachment 507472 [details] [diff] [review]
patch

Adds code to enable / disable the "Connect" button. Checks when opening the manual dialog and as you type in the account, password and synckey fields. All fields must have some text before the "Connect" button is enabled.
Attachment #507472 - Flags: review?(21)
Comment on attachment 507472 [details] [diff] [review]
patch

>diff --git a/chrome/content/sync.js b/chrome/content/sync.js

>+    if (account && password && synckey)
>+      document.getElementById("syncsetup-button-connect").disabled = false;
>+    else
>+      document.getElementById("syncsetup-button-connect").disabled = true;
>+  },

Nit:
let disabled = !(account && password && synckey);
document.getElementById("syncsetup-button-connect").disabled = disabled;
Attachment #507472 - Flags: review?(21) → review+
pushed with nit fixed:
http://hg.mozilla.org/mobile-browser/rev/ba751c096419
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 8

8 years ago
verified fixed on build id: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b13pre)
Gecko/20110304 Firefox/4.0b13pre Fennec /4.0b6pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.