Form submission using image as submit button no longer works

RESOLVED INVALID

Status

()

Core
HTML: Form Submission
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Ruben, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

When I made a input button with image (<input name="enviar" type="image">).
This don't work with FireFox 4 (equal that IExplorer 6) when the User press the button, but work perfect with Mozilla Firefox 3.6.

Reproducible: Always

Steps to Reproduce:
1. Made the button
2. Go to the webpage
3. Click the button
Actual Results:  
The user can't proceed into the webpage.

Expected Results:  
Only need fix the bug equal that Mozilla Firefox 3.6
Can you attach a Testcase showing the Issue?

Comment 2

7 years ago
Bump for comment 1.

Could you also see if the issue occurs...
- With a new, empty profile:
http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_make-a-new-profile
- Using the latest nightly:
http://nightly.mozilla.org/
Component: General → HTML: Form Submission
Keywords: regression, testcase-wanted
Product: Firefox → Core
QA Contact: general → form-submission
Version: unspecified → Trunk
(Reporter)

Comment 3

7 years ago
(In reply to comment #1)
> Can you attach a Testcase showing the Issue?

M...
Try to do something here a shor time.

I did not answer before because I received no answer by email: S
What I understand is that <input type='image'> no longer submits the form which isn't true as far as I've tested. Ruben, is that the issue you are seeing?
A more described issue would be great. A testcase would be awesome :)
(Reporter)

Comment 5

7 years ago
Sorry for the later.

A page to test:
http://powerofdark.es/submitfail/


Sorry for the bad english, I spanish :)

Comment 6

7 years ago
Using the URL given in comment 5, confirmed using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110103 Firefox/4.0b9pre ID:20110103030359. (After clicking the yellow image on the page, the green text at the top changes if the form submitted ok).

Regression, since works in 3.6.13.

Last good nightly: 2010-02-24 
First bad nightly: 2010-02-25

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ddfecbc93934&tochange=a29d44f196a6

In this range are things like bug 544698 and bug 546528, which make some significant changes to form submission code and so presumably are related. CCing Jonas for feedback, since not sure which of those bugs (if any) to blocking with this one.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Keywords: testcase-wanted → testcase

Updated

7 years ago
Summary: Error on input button with image → Form submission using image as submit button no longer works
Ruben: We made an intentional change in Firefox 4 to match the HTML5 specification as well as the behavior of IE (at least versions 6 through 9).

We used to submit:

Submit.x=128&Submit.y=28&Submit=Enviar

Now we just submit:

Submit.x=128&Submit.y=28


This matches what IE does and what the HTML5 specification says to do.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Updated

7 years ago
blocking2.0: ? → -
(Reporter)

Comment 8

7 years ago
sorry for bothering.

I tested this bug the day that I publish (2~3 weeks) and I don't re-test with Mozilla 4.


Thanks all for resolve my doubt.


Regards!
Blocks: 544698
Duplicate of this bug: 644138
Duplicate of this bug: 645414
Duplicate of this bug: 656961
You need to log in before you can comment on or make changes to this bug.