css3flexbox : provide a min|max|width|height css value to make elements have the same size for grids and nested grids

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
--
enhancement
RESOLVED INVALID
7 years ago
4 years ago

People

(Reporter: Giorgio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101214 Firefox/4.0b8pre
Build Identifier: 

in flexbox grids, every box of a set of columns or rows obtains a same common min-max-width-height value assigned at every box of the same set

for example: this appears like a grid, because minmax-width are forced to be the same in every column and row:

<style>
grid r x
{
min-width:5px;
max-width:200px;
}
</style>

<grid>
<r><x>________</x><x flex="1">_________</x><x>____________</x></r>
<r><x>____</x><x flex="1">____</x><x>____</x></r>
</grid>

so in the standardized flexbox, why not provide a way to force a group of box to have the same dimensions?

for example

grid > columns > column > box
{
     width-group:elements(grid > columns > column > box);
}

means that min-width and max-width are overridden with a common value that matches every box

in plus with classic flexbox grid i can not create nested-level grids that matching the same columns and rows sizes (for example xul's <tree>)
with this solution i think yes

i really hope to have suggested a implementable thing

thank you for your time :)


Reproducible: Always
(Reporter)

Updated

7 years ago
Component: General → Style System (CSS)
QA Contact: general → style-system

Comment 1

4 years ago
Are you proposing a spec change? Then please contact the CSSWG (http://csswg.org/). 

Also, the spec has changed a lot since you filed the bug, so you may want to revisit your suggestion before submitting a new request. 

This bug is INVALID, then.
Resolving as INVALID per comment 1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.