Password can be seen after a failed login

RESOLVED INVALID

Status

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: ioana.chiorean, Assigned: mbrubeck)

Tracking

Trunk
ARM
Android

Details

(Whiteboard: [Fennec 4.0b3])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 497758 [details]
pass not hidden

Build Identifier: Mozilla/5.0 (Android; Linux armv7l; rv:2.0b8pre)
Gecko/20101214 Firefox/4.0b8pre Fennec/4.0b3pre 
Device HTC Desire A8181

Steps to reproduce:
1. Go to www.mozilla.org -> Tap favicon - > Share page -> Facebook
2. Enter your account credentials but a wrong pass or user -> error appears for wrong pass or user
3. Re-enter the password

Expected result:
- the password can't be seen, is  hidden under ****

Actual result:
- the password can be seen, is not hidden under ****

Note: - see attached photo
(Reporter)

Updated

8 years ago
Whiteboard: [Fennec 4.0b3]

Comment 1

8 years ago
flagging for blocking
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0b3+
(Assignee)

Comment 2

8 years ago
Created attachment 497947 [details]
screenshot

It looks like this is intentional behavior by m.facebook.com after password entry fails.  See the attached screenshot.
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

8 years ago
It might be intended but I could only reproduce it on Fennec, nor on the Native Browser (Android and Maemo 5)
You need to log in before you can comment on or make changes to this bug.