nsILoginManager::addLogin NS_ERROR_XPC_JS_THREW_STRING

RESOLVED DUPLICATE of bug 609380

Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 609380
7 years ago
7 years ago

People

(Reporter: juanb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 497850 [details]
about sync log

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9pre) Gecko/20101215 Firefox/4.0b9pre

Using the latest nightly I tried to setup Sync with my existing account. I have been using my account with a 3.6x/1.6b5 and other instances of Minefield in other operating systems. When I tried to set it up it generated sets of four characters, but I cannot "Add a New Device" when using the extension in 3.6x so I used the option "I don't have my device" and I entered my account/password and copy/pasted my key from the extension to the nightly.

Every time I sync I get the error message in the summary. The data seems to be synchronized though. And I get this set of error messages:

Error: [Exception... "'Can't add a login with both a httpRealm and formSubmitURL.' when calling method: [nsILoginManager::addLogin]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: resource://services-sync/engines/passwords.js :: PasswordStore__create :: line 192"  data: no]
Source File: resource://services-sync/engines/passwords.js
Line: 192
Error: [Exception... "'Can't add a login with both a httpRealm and formSubmitURL.' when calling method: [nsILoginManager::addLogin]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: resource://services-sync/engines/passwords.js :: PasswordStore__create :: line 192"  data: no]
Source File: resource://services-sync/engines/passwords.js
Line: 192

Error: [Exception... "'Error: NS_ERROR_XPC_JS_THREW_STRING' when calling method: [nsIStreamListener::onStopRequest]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "<unknown>"  data: no]
(Reporter)

Comment 1

7 years ago
Not all of my saved passwords seem to have been sync'd. For example, I have several gmail accounts, and most of them are listed in the drop-down, but at least the most common one isn't there.

Should this ring any alarms or is this problem with my profile and one that probably most people will not experience?
Smells like a dupe of bug 609380.
Summary: Sync encountered an error while syncing: Unknown error. Sync will automatically retry this action. → nsILoginManager::addLogin NS_ERROR_XPC_JS_THREW_STRING
(If you already made out the error in the logs, please put it in the bug summary. Quoting the generic "Unknown Error" message isn't helpful at all.)
(Reporter)

Comment 4

7 years ago
Comment #3 makes me feel like you don't appreciate my trying to help, Phillip.
(In reply to comment #4)
> Comment #3 makes me feel like you don't appreciate my trying to help, Phillip.

Not at all. Sorry if I came across that way. I did use "please" btw. Also, this being a bug tracker and all, there'll be times when people will point things out that can be improved. My advice is to not take it personally because it rarely is meant that way.
Pretty sure this is a dupe of bug 609380.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 609380
You need to log in before you can comment on or make changes to this bug.