Closed Bug 61947 Opened 20 years ago Closed 19 years ago

Progress meter time left wrong

Categories

(SeaMonkey :: UI Design, defect, P3, minor)

x86
Linux

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.8

People

(Reporter: steve, Assigned: mscott)

References

Details

(Whiteboard: [nsbeta1+])

Attachments

(2 files)

I just did a 9MB FTP download, and its estimate of the time remaining was pretty
poor -- it said 25 seconds were left just before it finished.
Confirming. I noticed this yesterday - it doesn't appear to take into account
the time taken to select the download location, when mozilla is still
downloading anyway.  I waited 10 seconds from the time the dialog came up to
presing OK, and at the end of the download I was told that I had 8 seconds
remaining. I tried anoth file, waited 30 seconds before pressing OK, and at the
end I was told that I had 35 seconds to go. Since it was only counting down in
lots of 5 seconds, those are quite accurate except for the offset.

downloadProgress.js probably shouldn't be setting the start time to the current
time in onProgress. The %age bar was accurate, but the elapsed time was
incorrect (it started from 00:00, and it shouldn't have, because the downloading
started immediately.

That was on an HTTP download - changing componant.
Assignee: dougt → trudelle
Status: UNCONFIRMED → NEW
Component: Networking: FTP → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: tever → jrgm
-> XPApps: GUI Features - "Problems with the dialogs associated with 
downloading/saving files."
Assignee: trudelle → ben
Component: XP Toolkit/Widgets → XP Apps: GUI Features
QA Contact: jrgm → sairuh
bill or mscott, does this belong to you? sounds like a recent regression.
this belongs to me. 
Assignee: ben → mscott
Blocks: 62354
I fixed this along with something else. Adding appropriate triage keywords.
Status: NEW → ASSIGNED
Keywords: nsbeta1
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.8
this is now fixed. when you first see the progress dialog the Elasped time field
now counts the time we were downloading while the Open/Save dialog was open.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
*** Bug 69037 has been marked as a duplicate of this bug. ***
vrfy fixed --ie, the Elapsed Time does take into account the time while the
Downloading and Save file picker dialogs were displayed [ie, includes initial
background downloading time]:

linux comm 2001.05.02.08
mac comm 2001.05.02.09
winnt moz 2001.05.02.12
Status: RESOLVED → VERIFIED
Okay, I'm seeing this again.  Actually, the numbers are strange, more like bug
69307 with figures like "0-13:0-11" (but that was marked as a dupe of this).  

It doesn't help that the file size has been reported as smaller than it really
is.  I'm downloading a 110 meg file, but mozilla thinks it's only 41 megs. 
Don't know if that's a cause or a symptom.
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.