Closed Bug 619485 Opened 9 years ago Closed 9 years ago

add WebGL info to about:support

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: vlad, Assigned: vlad)

References

(Blocks 1 open bug)

Details

(Keywords: late-l10n, Whiteboard: [strings])

Attachments

(1 file, 1 obsolete file)

It's a bit roundabout, since I want it to go through the same creation dance that WebGL contexts normally go through.
Attachment #497894 - Flags: review?(jmuizelaar)
Comment on attachment 497894 [details] [diff] [review]
add webgl renderer info to about:support

I'd rather we not have two copies of GetWebGLParameter
Yeah, me too, though the way to avoid that was going to be to introduce GfxInfoBase.cpp in xpwidgets, which means that every gfxinfo method has to be declared manually in the child gfxinfo classes.  Kind of ugly.

Maybe a GfxInfoWebGLParameterImpl.cpp that can be #included?
Duplicate of this bug: 591627
Version: unspecified → Trunk
Attached patch updatedSplinter Review
Updated, with more shared code and a string bundle (needs late-l10n I guess?)
Assignee: nobody → vladimir
Attachment #497894 - Attachment is obsolete: true
Attachment #498156 - Flags: review?(jmuizelaar)
Attachment #497894 - Flags: review?(jmuizelaar)
Attachment #498156 - Flags: review?(jmuizelaar) → review+
Keywords: late-l10n
Whiteboard: [strings]
http://hg.mozilla.org/mozilla-central/rev/075bb085d755
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Mozilla/5.0 (X11; Linux i686; rv:2.0b13pre) Gecko/20110226 Firefox/4.0b13pre

Should this always display something? I'm using the latest trunk nightly on Linux and all I see in the Graphics section is:

"Graphics

GPU Accelerated Windows 0/1"

WebGL is working, as verified by running a few demos.
This is not yet implemented on X11; will be in Firefox 5.
You need to log in before you can comment on or make changes to this bug.