Last Comment Bug 619515 - Creating new event requires more clicks compared to previous releases
: Creating new event requires more clicks compared to previous releases
Status: RESOLVED FIXED
: regression
Product: Calendar
Classification: Client Software
Component: Dialogs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: 1.0b3
Assigned To: Decathlon
:
:
Mentors:
: 623607 (view as bug list)
Depends on:
Blocks: 366139
  Show dependency treegraph
 
Reported: 2010-12-15 14:54 PST by Stefan Sitter
Modified: 2013-02-21 22:57 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Stefan Sitter 2010-12-15 14:54:06 PST
Using Lightning 1.0b3pre with Lanikai 3.1.8pre from today.

Creating a new event now requires more clicks compared to previous Sunbird and Lightning releases. This is probably caused by the change for Bug 366139.

Steps to Reproduce:
1) Start creating new event
2) Set start date and time
3) Set end date and time
4) Save event

Actual Results:
This are the same steps used in previous Sunbird and Lightning releases as well as other calendar software I tested. But the event did not saved as specified because after step 3 the start date is suddenly changed without notice. One has to reopen the event, disable the link icon, reset start/end date/time and save again.

Expected Results:
In my opinion a new features should make it easier for users. But now it is actually more complicated to create the event. The default behavior should match the easier behavior known from previous releases. Otherwise I expect a lot of support request, bug reports and similar until you told every user to always disable the link icon when creating event.
Comment 1 Decathlon 2010-12-16 05:02:39 PST
(In reply to comment #0)
> This are the same steps used in previous Sunbird and Lightning releases as well
> as other calendar software I tested. But the event did not saved as specified
> because after step 3 the start date is suddenly changed without notice.

Might it help to set a default "unlinked" status for the button? In this way the workflow would be the same immediately at the first run of Lightning and, at the same time, the user is noticed about the interface's behavior by the  the icon on the button (instead before no element noticed the user that when he changed the start date, the end date changed too (bug 366139).
However the button keeps the status between different new events and between sessions so the user can choose his preferred behavior and change it only when it needs.
Comment 2 Stefan Sitter 2011-01-06 08:27:59 PST
*** Bug 623607 has been marked as a duplicate of this bug. ***
Comment 3 Decathlon 2013-02-17 04:02:15 PST
The default status of the keep-duration button has been changed with patches for bug 366139 in order to restore the previous behavior and fixing this bug.

Note You need to log in before you can comment on or make changes to this bug.