Creating 2 profiles which functions as one

VERIFIED DUPLICATE of bug 113203

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED DUPLICATE of bug 113203
17 years ago
2 years ago

People

(Reporter: richard pecson, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
mozilla0.9.8
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: suntrak-n6)

(Reporter)

Description

17 years ago
steps

1. delete appreg from your .mozilla directory
2. run ./netscape -ProfileManager (will display Profile Manager with no listed
profiles)
3. create a "user" profile (in .mozilla it will create a "user" directory)
4. after creating "user" in profile manager, rename it to "user1" (in .mozilla,
user1 profile will still use the "user" directory)
5. still from the Manager, create another profile named "user"
6. From the profile manager, the profiles listed there should be "user" and "user1"
7. select user profile and start netscape 6, setup your im account and proxies.
9. exit netscape 6 and launch it again (./netscape -ProfileManager)
10. this time, use user1 as your profile, the setup you made in user profile
will still reflect in this user1 profile (e.g. im account and proxies)

There are 2 profiles listed but it's like you're just using one, updating the
user profile will automatically update user1 and vice versa...
(Reporter)

Comment 1

17 years ago
adding sun tracking string
Whiteboard: suntrak-n6

Comment 2

17 years ago
Profile Manager FE bugs --> me
Assignee: ben → blakeross

Comment 3

17 years ago
-> Ben
Assignee: blake → ben
Sounds like a back end bug... shouldn't creating a new profile with a name 
identical to an existing subfolder create a new subfolder under that name with 
a randomized name? 

e.g. for two profiles in 

.mozilla/user/sdfhwekr.slt/   <-- profile originally "user" now "user1"
.mozilla/user/234wkrej.slt/   <-- newly created "user" 
Assignee: ben → ccarlen
Component: Profile Manager FrontEnd → Profile Manager BackEnd
QA Contact: gbush → ktrina
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 5

16 years ago
Same problem as in bug 113203. Marking as dup.

*** This bug has been marked as a duplicate of 113203 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
Verified as a dupe of bug 113203
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.