Closed Bug 619563 Opened 9 years ago Closed 5 years ago

Amazon.com web page causes multiple consecutive sec_error_untrusted_issuer modal dialogs to pop up

Categories

(Core :: Security: PSM, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: briansmith, Unassigned)

References

Details

http://www.amazon.com/Ghost-Map-Londons-Terrifying-Epidemic/dp/1594482691/

Brendan Eich is able to reproduce this at will on a non-mozilla-central build (JaegerMonkey/TraceMonkey?) on his MacBook Pro but I cannot reproduce it at all. He said he has been able to reproduce this for at least a few days. Possible causes include the update to NSS 3.12.9. Beltzner also said he saw it on with FaceBook Connect on some sites.

Could be related to / duplicate of bug 613977.
My build is optimized, pulled from tracemonkey c86a79eb18b9 (cc'ing sayrer).

/be
If anybody notices this error again, please inspect the certificate chain that caused the error to see if it looks wrong like the one attached to bug 634074.
See Also: → 634074
1. The root cause of the failure to load the sub-resources was fixed with the switch to mozilla::pkix, bug 915930.
2. Long before that we removed the dialog box that popped up when subresources failed to load due to cert validation failures.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: mozilla::pkix
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.