Closed Bug 619601 Opened 9 years ago Closed 6 months ago

Crash [@ _moz_cairo_surface_create_similar ]

Categories

(Core :: Graphics, defect, P3, critical)

x86
Windows
defect

Tracking

()

RESOLVED WONTFIX
mozilla2.0

People

(Reporter: alice0775, Assigned: tnikkel)

References

()

Details

(Keywords: crash, regression, Whiteboard: [approved-patches-landed][gfx-noted])

Crash Data

Attachments

(1 file)

Build Identifier:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101215 Firefox/4.0b9pre ID:20101215030322

Browser crashes randomly with crash reports after loading URL, and also crashes during restore session.
Maybe this crash is due to add-ons.


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open any page in tabs more than 15.
3. Open URL ( http://www.youtube.com/watch?v=BH0BNbwqNK8&webm=1&html5=1 )
4. Restart browser with session restore

Actual Results:
 Browser crashes randomly in step 3 or step 4.

Expected Results:
 No crashes.
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/1a149c7a4fa2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101209 Firefox/4.0b8pre ID:20101209191612
Fails:
http://hg.mozilla.org/mozilla-central/rev/8be85c96f560
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101209 Firefox/4.0b8pre ID:20101209203804
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1a149c7a4fa2&tochange=8be85c96f560
Blocks: 615782
Keywords: regression
dup of bug 619044, but might be better to dupe that one forward
Duplicate of this bug: 619044
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch patchSplinter Review
I guess we have to restore the null check for now, and try to reproduce and investigate this crash.
Assignee: nobody → tnikkel
Attachment #498036 - Flags: review?(jmuizelaar)
Attachment #498036 - Flags: review?(jmuizelaar) → review+
Attachment #498036 - Flags: approval2.0+
The null check patch landed
http://hg.mozilla.org/mozilla-central/rev/a5413c3c1013
but I'm keeping this open to investigate the root cause.
This seems to have caused 3.33% Ts regression on OSX 10.5 and 1.6% Ts regression on XP.

Is this expected?
That's probably impossible. More likely is that the places merge on revision before is the cause. I've seen the automated mails blame one or more changesets after the one that caused the improvement/regression many times before.
Whiteboard: [approved-patches-landed]
Crash Signature: [@ _moz_cairo_surface_create_similar ]
Timothy, do you have any intention of investigating this? If not, we could probably find someone to, though it doesn't seem like a high priority :/
I tried reproducing but failed to do so, and then that was it.
I still see reports of this in the wild but at extremely low volume. As an example: bp-a5d70c36-f73c-41c3-b5d6-79b412160427 (Firefox 45.0.2 on Windows XP).
OS: Windows 7 → Windows
Whiteboard: [approved-patches-landed] → [approved-patches-landed][gfx-noted]

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.