Lightning build does not function

RESOLVED DUPLICATE of bug 591744

Status

--
critical
RESOLVED DUPLICATE of bug 591744
8 years ago
8 years ago

People

(Reporter: valsodarg, Unassigned)

Tracking

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-CA; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.04 (lucid) Firefox/3.6.13
Build Identifier: 20101215212736

The nightly build no longer works for Linux 64 bit. The build (1.1a1pre Build Id: 20101215212736) does not operate at all - no data is loaded from the database, no calendars are listed, unable to create/add new ones. An older build of the calendar (1.1a1pre Build Id:20100415233015) works correctly. I have attempted this on thunderbird nightly (build on same date as lightning) and and older version of thunderbird (build on April 15th). Both were build the same way (see additional information for build configuration)

Reproducible: Always

Steps to Reproduce:
1.Build new lightning extension
2.Install extension
3.Try to interact
Actual Results:  
Unable to interact at all - can't create new calendar, or delete existing, does not display any events and is unable to create new ones. Nothing is displayed.


mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-thunderbird-@CONFIG_GUESS@
#mk_add_options AUTOCONF=autoconf2.13
#mk_add_options MOZ_CO_PROJECT=mail
mk_add_options MOZ_MAKE_FLAGS="-j8"

ac_add_options --enable-application=mail
ac_add_options --enable-calendar

#Optimization
ac_add_options --disable-debug
ac_add_options --disable-tests
ac_add_options --enable-optimize=-O3
ac_add_options --with-pthreads
ac_add_options --enable-strip

#Features
ac_add_options --disable-accessibility
ac_add_options --disable-updater
ac_add_options --disable-installer
ac_add_options --enable-xinerama

# Libraries / Dependencies
ac_add_options --enable-libnotify
ac_add_options --enable-gnomevfs
#ac_add_options --enable-default-toolkit=cairo-gtk2
#ac_add_options --enable-system-cairo
#ac_add_options --with-system-nss
#ac_add_options --with-nss-prefix=/home/$USER
#ac_add_options --with-system-nspr
#ac_add_options --with-nspr-prefix=/home/$USER
#ac_add_options --enable-system-sqlite

#ac_add_options --disable-debugger-info-modules
#ac_add_options --enable-extensions=default 
#ac_add_options --enable-default-toolkit=cairo-gtk2
#ac_add_options --enable-xft 
#ac_add_options --enable-static --disable-libxul
#ac_add_options --enable-ctl
#ac_add_options --enable-dbus
#ac_add_options --enable-gnomeui
#ac_add_options --enable-help-viewer


#ac_add_options --disable-codesighs
#ac_add_options --disable-glibtest
#ac_add_options --disable-jprof
#ac_add_options --disable-libIDLtest
#ac_add_options --disable-logging
#ac_add_options --disable-logrefcnt
#ac_add_options --disable-perf-metrics
#ac_add_options --disable-shark
#ac_add_options --disable-activex --disable-activex-scripting
#ac_add_options --disable-crashreporter
#ac_add_options --disable-debug-modules


#ac_add_options  --disable-dtrace
#ac_add_options  --enable-gnomevfs
#ac_add_options  --enable-boehm 
#ac_add_options  --enable-chrome-format=jar 
#ac_add_options  --enable-cookies
#ac_add_options  --enable-cpp-exceptions
#ac_add_options  --disable-eazel-profiler-support
#ac_add_options  --disable-efence
#ac_add_options  --disable-elf-dynstr-gc
#ac_add_options  --disable-feeds
#ac_add_options  --disable-freetypetest
#ac_add_options  --disable-image-encoders[={mod1,mod2,default,all,none}]
#ac_add_options  --disable-inspector-apis
#ac_add_options  --disable-install-strip
#ac_add_options  --disable-insure
#ac_add_options  --disable-ipcd
#ac_add_options  --disable-jemalloc
#ac_add_options  --disable-js-static-build
#ac_add_options  --disable-js-ultrasparc
#ac_add_options  --disable-jsd
#ac_add_options  --disable-jsloader
#ac_add_options  --disable-ldap
#ac_add_options  --disable-ldap-experimental
#ac_add_options  --disable-leaky
#ac_add_options  --disable-long-long-warning
#ac_add_options  --disable-mailnews
#ac_add_options  --disable-mathml
#ac_add_options  --disable-md
#ac_add_options  --disable-native-uconv
#ac_add_options  --disable-necko-disk-cache
#ac_add_options  --disable-necko-protocols[={http,ftp,default,all,none}]
#ac_add_options  --disable-necko-small-buffers
#ac_add_options  --disable-negotiateauth
#ac_add_options  --disable-official-branding
#ac_add_options  --disable-oji
#ac_add_options  --disable-old-abi-compat-wrappers
#ac_add_options  --disable-parental-controls
#ac_add_options  --disable-permissions
#ac_add_options  --disable-places
#ac_add_options  --disable-plaintext-editor-only
#ac_add_options  --disable-postscript
#ac_add_options  --disable-prebinding
#ac_add_options  --disable-pref-extensions
#ac_add_options  --disable-printing
#ac_add_options  --disable-profile-guided-optimization
#ac_add_options  --disable-profile-modules
#ac_add_options  --disable-profilelocking
#ac_add_options  --disable-profilesharing
#ac_add_options  --disable-quantify
#ac_add_options  --disable-rdf
#ac_add_options  --disable-reflow-perf
#ac_add_options  --disable-safe-browsing
#ac_add_options  --disable-startup-notification
#ac_add_options  --disable-static-mail
#ac_add_options  --disable-storage
#ac_add_options  --disable-strip
#ac_add_options  --disable-svg
#ac_add_options  --disable-svg-foreignobject
#ac_add_options  --disable-timeline
#ac_add_options  --disable-trace-malloc
#ac_add_options  --disable-ui-locale=ab-CD
#ac_add_options  --disable-universalchardet
#ac_add_options  --disable-url-classifier
#ac_add_options  --disable-v1-string-abi
#ac_add_options  --disable-view-source
#ac_add_options  --disable-webservices
#ac_add_options  --disable-wrap-malloc
#ac_add_options  --disable-xmlextras
#ac_add_options  --disable-xpcom-fastload
#ac_add_options  --disable-xpcom-lea
#ac_add_options  --disable-xpcom-obsolete
#ac_add_options  --disable-xpconnect-idispatch
#ac_add_options  --disable-xpctools
#ac_add_options  --disable-xpfe-components
#ac_add_options  --disable-xpinstall
#ac_add_options  --disable-xterm-updates
#ac_add_options  --disable-zipwriter
(Reporter)

Comment 1

8 years ago
Created attachment 498003 [details]
What is shown in the calendar tab
(Reporter)

Comment 2

8 years ago
Created attachment 498004 [details]
Same view of the calendar tab with the right click menu shown

As you can see most items are greyed. I also did the same for the calendar column but these options were all greyed except export calendar.
(Reporter)

Comment 3

8 years ago
Created attachment 498005 [details]
What is shown in the calendar tab

sorry had to remove some semi sensitive info (chat login name)
Attachment #498003 - Attachment is obsolete: true
Please check Tools > Error Console for calendar related error messages.
Trunk builds are known to be broken, see e.g. Bug 591744. 

Keep in mind that 64-bit builds are not yet supported. Therefore always test too with the official Thunderbird and Lightning nightly builds.
(Reporter)

Comment 5

8 years ago
Thank you.
I believe that this is a duplicate of Bug 591744
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591744
You need to log in before you can comment on or make changes to this bug.