Saved passwords do not work on live.com

RESOLVED DUPLICATE of bug 355063

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 355063
7 years ago
7 years ago

People

(Reporter: Marcin Wisnicki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0E)

My Firefox has saved password for "https://login.live.com".
When I enter that page I'm greeted with empty login form on the left.
Using "remember passwords" bookmarklet reports that 0 forms were fixed, indeed the form does not use autocomplete attribute.

Double clicking on username (Windows LiveID) field presents me with 10 different unrelated logins from my password manager. There is nothing that connects them with the current website nor with each other. It seems like a  random choice but they are always the same.

Selecting any of them (including the correct one) does nothing, ie. password field stays empty.

Entering password and clicking "Sign In" does not result in any message from password manager.

Live.com used to cause me troubles before but now I can't make it to work at all.

Reproducible: Always

Steps to Reproduce:
1. Go to https://login.live.com/
2. Try to login
3. Password is not saved

Comment 1

7 years ago
live.com generates the form through scripts, so the password manager doesn't catch it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355063
You need to log in before you can comment on or make changes to this bug.