Closed Bug 619808 Opened 9 years ago Closed 9 years ago

Sync errors are not localized for beta 3

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0b4+)

VERIFIED FIXED
Tracking Status
fennec 2.0b4+ ---

People

(Reporter: tchung, Assigned: Pike)

References

Details

Attachments

(1 file)

while the sync setup screens are localized for some of the locales, the error messages aren't.  Messages like "Wrong Sync Key", "Unknown Errors", "Unable to sync", etc..   

Should these be blocking beta 3 or pushed to future?   

Repro:
1) install fennec 4 beta 3 on android, multi-locale build
2) change to a tier 1 locale (eg. French, Italian)
3) try to sync
4) Verify the easy setup and fallback UI screens are localized, but the error messages (when you cannot sync), are not.

Expected:
- Error messages for syncing should be localized

ActuaL:
- error messages still in english.
tracking-fennec: --- → ?
Blocks: 619231
We are pulling error messages from the toolkit sync code, not from Fennec
blocking2.0: --- → ?
tracking-fennec: ? → 2.0b4+
Product: Fennec → Mozilla Services
QA Contact: general → general
Version: Trunk → unspecified
They are localized in Sync and show up translated in localized versions of Firefox. Perhaps you're not pulling in the right bits anymore. I definitely remember this was a problem in the past (bug 605414).

Anyway, doesn't seem like a Sync bug to me.
Axel, do you have any idea what could be causing this?
Looking at http://releases.mozilla.org/pub/mozilla.org/mobile/releases/4.0b3/android-r7/multi/fennec-4.0b3.multi.eabi-arm.apk:

The fr.manifest doesn't include a line for

locale weave en-US en-US/locale/en-US/


http://hg.mozilla.org/mobile-browser/annotate/FENNEC_4_0b3_RELEASE/locales/Makefile.in on the other hand says that it should be building services/sync.

Over to releng for investigation.
Component: General → Release Engineering
Product: Mozilla Services → mozilla.org
QA Contact: general → release
Version: unspecified → other
Actually I bet this is a bad fix in bug 606725. Doh, I reviewed that. I forgot way too much about how things worked there.

I'm pretty sure it shouldn't have XPI_NAME and BOTH_MANIFESTS for chrome-%.

Back over to fennec.
Component: Release Engineering → General
Depends on: 606725
Product: mozilla.org → Fennec
QA Contact: release → general
Version: other → Trunk
Mark, I only tested the output of the chrome-% target. With these changes, the french services files are in and fr.manifest lists them. Should be good. I don't have a device to test an actual build, though.
Assignee: nobody → l10n
Status: NEW → ASSIGNED
Attachment #499645 - Flags: review?(mark.finkle)
Attachment #499645 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/27501148f792, FIXED.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
blocking2.0: ? → ---
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110526 Firefox/7.0a1 Fennec/7.0a1 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.