bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Sync "failed to connect" error when using master password and a proxy

RESOLVED DUPLICATE of bug 612262

Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 612262
8 years ago
8 years ago

People

(Reporter: liznben@gmail.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101215 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101215 Firefox/4.0b9pre

If I start firefox, and the first thing I do is try to sync to pickup some stuff from another computer, I get prompted for my master password.  After entering the master password, sync will fail every time I try to do it, with the error "Failed to connect".

However if I *first* visit a webpage, I get prompted for my master password, and THEN I get prompted to confirm my proxy login details (which are autofilled), sync will then work.

Reproducible: Always

Steps to Reproduce:
1. Ensure you use a master password
2. Ensure you use a proxy (eg. at work)
3. Ensure no tabs are open that will make firefox connect to the proxy when you restart firefox
3. Exit and start firefox from fresh
4. Try to Sync 
Actual Results:  
1. You will get prompted for a master password, but you will **NOT** get prompted to confirm the proxy login details (the normal "Authentication Requred" box that pops up)
2. You will get a Sync error and sync will not work, even if you keep trying it.
3. If you now visit a webpage, you will not have to enter the master password but you will still have to confirm the proxy login 
4. After this sync will then work again

Expected Results:  
1. After you enter the master password, sync should then work.  
OR 
2. After you enter the master password, you should be prompted to confirm the proxy login details, and then sync should work.

I suspect the reason why the sync isn't working is because you don't get prompted to confirm the proxy login details.

Comment 1

8 years ago
Believe this is a dupe of bug 612262, can you confirm your issue still occurs even if no master password set? (In which case it definitely is a dupe)
Component: Account Manager → Firefox Sync: Backend
Product: Firefox → Mozilla Services
QA Contact: account.manager → sync-backend

Comment 2

8 years ago
Oh and see also: Bug 451371
(Reporter)

Comment 3

8 years ago
Bug still occurs if no master password, sorry, so you're correct its a duplicate of 612262.  I searched and didn't find this bug but I was presuming the master password was part of the problem and it was one of my search terms, sorry about that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 612262
You need to log in before you can comment on or make changes to this bug.