Last Comment Bug 619849 - JM: shrink JITScript on 64-bit platforms
: JM: shrink JITScript on 64-bit platforms
Status: RESOLVED FIXED
[cib-memory], fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nicholas Nethercote [:njn]
:
Mentors:
Depends on:
Blocks: JaegerShrink
  Show dependency treegraph
 
Reported: 2010-12-16 17:59 PST by Nicholas Nethercote [:njn]
Modified: 2011-01-04 18:14 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
betaN+


Attachments
patch (against TM 58597:dab87d48d3dd) (2.67 KB, patch)
2010-12-16 17:59 PST, Nicholas Nethercote [:njn]
dvander: review+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2010-12-16 17:59:59 PST
Created attachment 498271 [details] [diff] [review]
patch (against TM 58597:dab87d48d3dd)

JITScript is sub-optimally packed on 64-bit platforms.  The attached patch reduces its size from 232 to 200 bytes.  On a 20-tab cad-comics browser run, this saves 357,102 bytes.  It's a small win, but it's a dead-simple patch.
Comment 1 Nicholas Nethercote [:njn] 2010-12-19 19:57:48 PST
A |bool singleStepMode| field was added since I created the patch, I squeezed that into the bottom bit of |nCallSites|.

http://hg.mozilla.org/tracemonkey/rev/35697ebafa6c
Comment 2 Chris Leary [:cdleary] (not checking bugmail) 2011-01-04 14:53:23 PST
http://hg.mozilla.org/mozilla-central/rev/35697ebafa6c
Comment 3 christian 2011-01-04 15:47:29 PST
As per today's meeting, beta 9 will be a time-based release. Marking these all betaN+. Please move it back to beta9+ if you believe it MUST be in the next beta (ie: trunk is in an unshippable state without this)
Comment 4 christian 2011-01-04 18:14:37 PST
Fixing fields my automated script accidentally blanked. Apologies for the bugspam

Note You need to log in before you can comment on or make changes to this bug.