If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Use progressive enhancement or improve messaging around JavaScript functionality

RESOLVED FIXED

Status

Mozilla Developer Network
Editing
--
enhancement
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Benjamin Hawkes-Lewis, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_5; en-US) AppleWebKit/534.13 (KHTML, like Gecko) Chrome/9.0.597.19 Safari/534.13
Build Identifier: 

This message is now appearing at the top of most pages (not the homepage) on MDN when JS is disabled:

"This application requires Javascript to be enabled."

At first glance everything things to work however. The "Edit" link is still surfaced and confusingly presents the same page in a non-editable form.

This is bad firstly because it's confusing the message appears when viewing or editing documentation and because the site generally works without JS, it's not obvious that you need to enable JS in order to edit specifically. Even just changing the message to "You must enable Javascript to edit content." would be an improvement.

It would be even better if the site used progressive enhancement for editing:

https://wiki.mozilla.org/WebDev:FrontendCodeStandards

This would be more robust in the face off:

   1. Developers who habitually disable JS, like me.
   2. Network/JS errors that make the editor fail to load.
   3. Accessibility problems that might be experienced with the JS-dependent editing UI.

It's possible to edit Wikipedia without JS; I don't see why it shouldn't be possible to edit MDN.

The JS-dependent editor includes a "Source" button to allow you to edit raw code. When JS is disabled, couldn't the same code couldn't be surfaced in a "textarea", with a short style guide explaining any special tags or markup conventions?


Reproducible: Always
(Assignee)

Updated

5 years ago
Component: Docs Platform → Editing
Product: Mozilla Developer Network → Mozilla Developer Network
Our most recent design takes full advantage of progressive enhancement (thanks, Craig!). You can edit without JavaScript enabled and the site even works well in Lynx.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.