There is no jsval_layout definition for 64 bit big endian machines

RESOLVED DUPLICATE of bug 618485

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 618485
7 years ago
7 years ago

People

(Reporter: Martin Husemann, Unassigned)

Tracking

Trunk
Sun
NetBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
See js/src/jsval.h lines 274ff - there are versions defined for little endian 32bit, little endian 64 bit, and big endian 32bit - that's it.

I failed to guess why this union/structure would be endian dependend, so I don't know what to add, please advice!

Updated

7 years ago
Duplicate of this bug: 589472

Comment 2

7 years ago
Oops.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618485
You need to log in before you can comment on or make changes to this bug.