If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add-ons mistakenly labeled compatible with mobile/fennec 0.1 - 2.0a1pre

RESOLVED FIXED

Status

Add-on SDK
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: mbrubeck, Assigned: myk)

Tracking

({mobile})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
A number of add-ons by various authors are marked compatible with Mobile Firefox 0.1 to 2.0a1pre.  This appears to be unintentional and wrong.  These two examples are by Dietrich and Atul, and I confirmed with Dietrich that the compatibility information is wrong:

https://addons.mozilla.org/en-US/mobile/addon/182410/
https://addons.mozilla.org/en-US/mobile/addon/261037/

I suspect this is a problem with some template or default settings in the Add-On Builder, Jetpack SDK, or similar tool.
(Assignee)

Comment 1

7 years ago
We recently updated the Fennec compatibility min/max versions in the Add-on SDK to 4.0b3/4.0b3:

https://github.com/mozilla/addon-sdk/blob/master/python-lib/cuddlefish/app-extension/install.rdf#L28

Addons need to be rebuilt to reflect this change however.  And we should update the max version to be 4.0b4pre now that we've branched for 4.0b3.

-myk
(Assignee)

Updated

7 years ago
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
(Assignee)

Updated

7 years ago
QA Contact: jetpack-sdk → general
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> We recently updated the Fennec compatibility min/max versions in the Add-on SDK
> to 4.0b3/4.0b3:

Even this will be wrong for add-ons that use SDK features that don't work in Fennec.  For example, this add-on does not appear to work in Fennec but is marked compatible with Fennec 4.0b3pre-b4:
https://addons.mozilla.org/en-US/mobile/addon/hard-blockers-counter/

Should the SDK be marking add-ons compatible with Fennec by default, when Fennec does not have full SDK support yet?
(Assignee)

Comment 3

7 years ago
(In reply to comment #2)
> Should the SDK be marking add-ons compatible with Fennec by default, when
> Fennec does not have full SDK support yet?

Hmm, no, you're right.  Until we embark on a focused effort to make the SDK build Fennec-compatible addons and have confidence that most addons are Fennec-compatible by default, marking addons as Fennec-compatible should be opt-in rather than opt-out (as it is today).
Assignee: nobody → myk
Status: NEW → ASSIGNED
(Assignee)

Comment 4

7 years ago
Created attachment 512620 [details] [diff] [review]
patch v1: removes Fennec and Thunderbird target applications

This patch removes Fennec and Thunderbird from the list of target applications, since there is currently no manual or automated testing to verify that SDK-based addons work on those target applications.
Attachment #512620 - Flags: review?(warner-bugzilla)
Comment on attachment 512620 [details] [diff] [review]
patch v1: removes Fennec and Thunderbird target applications

looks good!
Attachment #512620 - Flags: review?(warner-bugzilla) → review+
(Assignee)

Comment 6

7 years ago
https://github.com/mozilla/addon-sdk/commit/99b1a19e2a710ed6f75d133bd4873c9a3575f691
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.