topcrash: from tb crash report

RESOLVED WORKSFORME

Status

()

P1
critical
RESOLVED WORKSFORME
18 years ago
7 years ago

People

(Reporter: buster, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

18 years ago
crash opening urls
http://www.wunderground.org
http://sql.interplus.ro

stack:
0x00000000
	 nsLineLayout::ReflowFrame()
	 nsBlockFrame::ReflowInlineFrame()
	 nsBlockFrame::DoReflowInlineFrames()
	 nsBlockFrame::DoReflowInlineFramesAuto()
	 nsBlockFrame::ReflowInlineFrames()
	 nsBlockFrame::ReflowLine()
	 nsBlockFrame::ReflowDirtyLines()
	 nsBlockFrame::Reflow()
	 nsBlockReflowContext::DoReflowBlock()
	 nsBlockReflowContext::ReflowBlock()
	 nsBlockFrame::ReflowBlockFrame()
	 nsBlockFrame::ReflowLine()
	 nsBlockFrame::ReflowDirtyLines()
	 nsBlockFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableCellFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableRowFrame::IR_TargetIsChild()
	 nsTableRowFrame::IncrementalReflow()
	 nsTableRowFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableRowGroupFrame::IR_TargetIsChild()
	 nsTableRowGroupFrame::IncrementalReflow()
	 nsTableRowGroupFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableFrame::IR_TargetIsChild()
	 nsTableFrame::IncrementalReflow()
	 nsTableFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableOuterFrame::OuterReflowChild()
	 nsTableOuterFrame::IR_InnerTableReflow()
	 nsTableOuterFrame::IR_TargetIsInnerTableFrame()
	 nsTableOuterFrame::IR_TargetIsChild()
	 nsTableOuterFrame::IncrementalReflow()
	 nsTableOuterFrame::Reflow()
	 nsBlockReflowContext::DoReflowBlock()
	 nsBlockReflowContext::ReflowBlock()
	 nsBlockFrame::ReflowBlockFrame()
	 nsBlockFrame::ReflowLine()
	 nsBlockFrame::ReflowDirtyLines()
	 nsBlockFrame::Reflow()
	 nsLineLayout::ReflowFrame()
	 nsBlockFrame::ReflowInlineFrame()
	 nsBlockFrame::DoReflowInlineFrames()
	 nsBlockFrame::DoReflowInlineFramesAuto()
	 nsBlockFrame::ReflowInlineFrames()
	 nsBlockFrame::ReflowLine()
	 nsBlockFrame::ReflowDirtyLines()
	 nsBlockFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableCellFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableRowFrame::IR_TargetIsChild()
	 nsTableRowFrame::IncrementalReflow()
	 nsTableRowFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableRowGroupFrame::IR_TargetIsChild()
	 nsTableRowGroupFrame::IncrementalReflow()
	 nsTableRowGroupFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableFrame::IR_TargetIsChild()
	 nsTableFrame::IncrementalReflow()
	 nsTableFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 nsTableOuterFrame::OuterReflowChild()
	 nsTableOuterFrame::IR_InnerTableReflow()
	 nsTableOuterFrame::IR_TargetIsInnerTableFrame()
	 nsTableOuterFrame::IR_TargetIsChild()
	 nsTableOuterFrame::IncrementalReflow()
	 nsTableOuterFrame::Reflow()
	 nsBlockReflowContext::DoReflowBlock()
	 nsBlockReflowContext::ReflowBlock()
	 nsBlockFrame::ReflowBlockFrame()
	 nsBlockFrame::ReflowLine()
	 nsBlockFrame::ReflowDirtyLines()
	 nsBlockFrame::Reflow()
	 nsBlockReflowContext::DoReflowBlock()
	 nsBlockReflowContext::ReflowBlock()
	 nsBlockFrame::ReflowBlockFrame()
	 nsBlockFrame::ReflowLine()
	 nsBlockFrame::ReflowDirtyLines()
	 nsBlockFrame::Reflow()
	 nsBlockReflowContext::DoReflowBlock()
	 nsBlockReflowContext::ReflowBlock()
	 nsBlockFrame::ReflowBlockFrame()
	 nsBlockFrame::ReflowLine()
	 nsBlockFrame::ReflowDirtyLines()
	 nsBlockFrame::Reflow()
	 nsContainerFrame::ReflowChild()
	 CanvasFrame::Reflow()
	 nsBoxToBlockAdaptor::Reflow()
	 nsBoxToBlockAdaptor::DoLayout()
	 nsBox::Layout()
	 nsScrollBoxFrame::DoLayout()
	 nsBox::Layout()
	 nsContainerBox::LayoutChildAt()
	 nsGfxScrollFrameInner::LayoutBox()
	 nsGfxScrollFrameInner::Layout()
	 nsGfxScrollFrame::DoLayout()

Comment 1

18 years ago
this is the trace from bug 61904, which seems to have been caused by forms.css
not being added to some of hyatt's checkins. All pages with forms crashed using
installed builds.
Pinkerton checked it the fix at around 1500H on the 4th.

Comment 2

18 years ago
I reopened 61904 for further triage.
Seems the related bugs (url-bar numb and scrollbars missing) have regressed
again. All these bugs appeared "together" in the same build, and were fixed by
pinkerton's checkin of forms.css

Which build is the latest talkback of this issued on? With the affected builds,
all pages with forms crash. Installed linux build ID 2000120421 was the first
after this affair that loaded them OK. Has it regressed again after that?
(Assignee)

Comment 3

18 years ago
WFM debug build 20001205 WinNT.  May have been a duplicate of bug 61904
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Depends on: 61904
Priority: P3 → P1
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.