7 zip and email does not work.

RESOLVED INVALID

Status

MailNews Core
Simple MAPI
RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: jjunkk, Unassigned)

Tracking

1.9.2 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

When trying to send a compressed file with "7zip", right click on the file and select (Compress to "file.7z" and email) an error message comes up that says

(There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel.)

Thunderbird is installed, and associated in the Default Programs control panel. It would be nice to be able to use this function. Why can't 7zip see Thunderbird?

Reproducible: Always

Steps to Reproduce:
1.Right click on file
2.Select (Compress to "file.7z" and email)
3.Error message (There is no email program associated to perform the requested action)
Actual Results:  
Recieved an error message that said  (There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel.)


Expected Results:  
Opened Thunderbird to alow me to email my compressed file.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1
Does the normal mail to menu item work ? (ie when you don't go thru 7 zip )?
Component: General → Simple MAPI
Product: Thunderbird → MailNews Core
QA Contact: general → simple-mapi
Version: 3.1 → 1.9.2 Branch
(Reporter)

Comment 2

8 years ago
You asked "Does the normal mail to menu item work" The answer is yes,
Thunderbird works fine except when compressing and emailing from 7 zip.
Thanks for taking the time for my issue.
My guess is that 7zip isn't using simple mapi :(
(Reporter)

Comment 4

8 years ago
Could you please forward this bug report to 7 zip.
7zip only issue? Send To/Mail Recipient of a file works? Bug 618678?
Check Windows registry key, and change to mozMapi32.dll if mozMapi32_InUse.dll. Is it a workaround?
(Reporter)

Comment 6

8 years ago
I followed the recomendations fron bug report 618678 and changed HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird\mozMapi32_InUse.dll to HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird\mozMapi32.dll. But it did not make any difference.

I also noticed that my thunderbird folder contains both mozMapi32_InUse.dll and mozMapi32.dll in it.
(Reporter)

Comment 7

8 years ago
I opened a report with SourceForge about this email problem with 7zip

https://sourceforge.net/tracker/?func=detail&aid=3142928&group_id=14481&atid=114481
It may be same issue as bug 546889.
Will hotfix of Win7's mapi module(simple mapi related) work?

Comment 9

6 years ago
Reporter, do you still see this problem when using version 10 or newer?

if you are unable to reproduce, please close by setting status to resolved, and resolution to WORKSFORME or another appropriate setting.

If you are able to reproduce, please add new details, and a testcase if one does not already exist in the bug report.
Whiteboard: [closeme 2012-03-25]
RESOLVED INCOMPLETE due to lack of response to last question. If you feel this change was made in error please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 11

6 years ago
Apparently 7zip was unable to resolve the issue.
7 zip has now removed the option to zip and e-mail.
This must have been there way of resolving the issue.
So still nothing has changed.
Same as before the bug report.
You have to compress a file with 7zip and then paste the compressed file into Thunderbird for e-mailing.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
If 7zip has removed the option, then there is nothing that Thunderbird could do to fix it anyways -> INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
Whiteboard: [closeme 2012-03-25]
You need to log in before you can comment on or make changes to this bug.