Last Comment Bug 619967 - non-directional filter primitive attributes with percentage values are not resolved correctly
: non-directional filter primitive attributes with percentage values are not re...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Robert Longson
:
Mentors:
http://dev.w3.org/SVG/profiles/1.1F2/...
Depends on:
Blocks: svg11tests 716347
  Show dependency treegraph
 
Reported: 2010-12-17 11:33 PST by Cameron McCormack (:heycam)
Modified: 2012-01-09 15:10 PST (History)
4 users (show)
cam: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot (70.06 KB, image/png)
2010-12-17 13:09 PST, Cameron McCormack (:heycam)
no flags Details
patch? (1.55 KB, patch)
2011-09-10 08:39 PDT, Robert Longson
roc: review+
cam: feedback+
Details | Diff | Splinter Review
test for attachment 559695 patch (518 bytes, image/svg+xml)
2011-11-13 02:49 PST, Cameron McCormack (:heycam)
no flags Details
patch adding a test (2.13 KB, patch)
2012-01-08 03:47 PST, Cameron McCormack (:heycam)
longsonr: review+
Details | Diff | Splinter Review

Description Cameron McCormack (:heycam) 2010-12-17 11:33:41 PST
http://dev.w3.org/SVG/profiles/1.1F2/test/harness/htmlObjectMiniApproved/filters-displace-02-f.html currently fails due to some strange colors near the edge of the displaced image.
Comment 1 Robert Longson 2010-12-17 12:46:55 PST
I can't see it. Can you describe in more detail. Maybe with a screenshot with the differences circled?
Comment 2 Cameron McCormack (:heycam) 2010-12-17 13:09:45 PST
Created attachment 498401 [details]
Screenshot

This might be a Mac only issue -- I haven't tried others yet.
Comment 3 Robert Longson 2011-09-10 08:39:33 PDT
Created attachment 559695 [details] [diff] [review]
patch?

Does this fix it? It seems the right thing to do according to http://www.w3.org/TR/SVG/coords.html#Units_viewport_percentage.

I don't know how to write a test for this.
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-09-13 08:34:53 PDT
It's a bit weird that 'scale' is described as a number in some places but is treated in the primitiveUnits coordinate system, so it's really a length. The spec could use some cleanup there.
Comment 5 Robert Longson 2011-10-24 06:32:36 PDT
Cameron, do you think you'll get a chance to check this patch out soon?
Comment 6 Cameron McCormack (:heycam) 2011-10-27 21:22:13 PDT
I will do so as soon as I return from my travels; ping me again if I don't respond before November 9.
Comment 7 Robert Longson 2011-11-10 07:15:00 PST
It's November 10th now :-)
Comment 8 Cameron McCormack (:heycam) 2011-11-13 02:48:02 PST
Sorry for the delay.  I took a look at the patch, and I think we want this fix, but it doesn't fix the problem for this particular bug (the strange aqua colours at the left edge of the gradient in the top subtest).  I'll attach a test for the scale="" coordinate space conversion problem that this patch fixes.

BTW, does this also affect some lighting filter primitives?  It looks like they might also have been using this function.
Comment 9 Cameron McCormack (:heycam) 2011-11-13 02:49:31 PST
Created attachment 574141 [details]
test for attachment 559695 [details] [diff] [review] patch
Comment 10 Cameron McCormack (:heycam) 2012-01-07 17:44:56 PST
Comment on attachment 559695 [details] [diff] [review]
patch?

We want this patch, but it doesn't fix this bug.
Comment 11 Robert Longson 2012-01-08 01:44:58 PST
Probably best to clone this bug and make the clone be about the original issue and then rename this one to what it fixes and land the patches. Can you do that Cameron please?
Comment 12 Cameron McCormack (:heycam) 2012-01-08 03:47:33 PST
Created attachment 586787 [details] [diff] [review]
patch adding a test

test as a patch
Comment 14 Robert Longson 2012-01-09 01:50:09 PST
Thanks Cameron and my apologies for muddying up this bug.

Note You need to log in before you can comment on or make changes to this bug.