Update the login page loop

VERIFIED FIXED in Builder 0.9.3

Status

P1
blocker
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: dbuchner, Assigned: smcarthur)

Tracking

unspecified
Builder 0.9.3

Details

(Reporter)

Description

8 years ago
In cases where the user is on a strictly informational page logging in should send the user to their My Account page. If it is any other type of page, they should return to the page they were previously viewing.
(Reporter)

Updated

8 years ago
Blocks: 619976
Priority: -- → P3
Target Milestone: -- → 0.8
Component: FlightDeck → Add-on Builder
Product: Mozilla Labs → addons.mozilla.org
Target Milestone: 0.8 → ---
QA Contact: flightdeck → add-on-builder
Target Milestone: --- → Builder 0.8
(Reporter)

Updated

8 years ago
Assignee: nobody → zaloon
Target Milestone: Builder 0.8 → Builder 0.9
Target Milestone: Builder 0.9 → Builder 0.9.1
(Reporter)

Comment 1

8 years ago
Has this been done? I think I remember seeing this happen now upon login.
No - it's not done yet
I will need to have a list of "Strictly informational pages" for the moment I'll build it in the way it will return to the current page.
https://github.com/zalun/FlightDeck/commit/308063d10c8effdb9ffd8f0450b91b1ea7b13e7b
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

8 years ago
"strictly informational page" - To be more clear, it should send you to My Account upon login from any page that is not an edit/view code page of a library or add-on.

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

8 years ago
See last comment
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 7

8 years ago
Piotr, we need this fixed P1 in the next few hours, ashah is unable to run his test without this working.
(Reporter)

Updated

8 years ago
Severity: normal → blocker
Priority: P3 → P1
Target Milestone: Builder 0.9.1 → Builder 0.9.3
(Assignee)

Comment 8

8 years ago
fixed this for now

https://github.com/mozilla/FlightDeck/commit/5c6c89da80337a8011a77b5cf83b93b5efaf7689
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Comment 9

8 years ago
Now, the editor pages have also been included in this redirect. I mean , even the editor pages are now redirected to dashboard which should not be the case.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

8 years ago
(In reply to comment #5)
> "strictly informational page" - To be more clear, it should send you to My
> Account upon login from any page that is not an edit/view code page of a
> library or add-on.

This is the intended behavior ^
(Assignee)

Comment 11

8 years ago
What pages? It works for me...
(Reporter)

Comment 12

8 years ago
Yeah I am no longer seeing this issue either, Ayan, can you give this user-flow one more try and let us know what happens?
looks on mine on my side as well - fixed
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Reopening as the following case fails:
1. on the home page, without signing in, click on view button of any add-on
2. once on the editor page, click on copy button. it will ask you to sign in
3. sign in

Result: you will be displayed the dashboard page instead of the editor page
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

8 years ago
Assignee: zaloon → smcarthur
(Assignee)

Comment 15

8 years ago
The link was coming from a different part of the template, so I forgot to update that part to use the new mechanism. This is fixed now as well

https://github.com/mozilla/FlightDeck/commit/b8a0cb428becd37099bc5ec805d61fa8f0f01d69
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.