Closed Bug 620028 Opened 9 years ago Closed 9 years ago

"Assertion failure: compartment mismatched" with uneval(InstallTrigger)

Categories

(Core :: XPConnect, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: jruderman, Assigned: gal)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase, Whiteboard: hardblocker, fixed-in-tracemonkey)

Attachments

(4 files, 2 obsolete files)

Attached file testcase
Assertion failure: compartment mismatched, at js/src/jscntxtinlines.h:541

Related to bug 611242?
Attached file stack trace
Attached file testcase 2: instanceOf
Attached patch Proposed fix v1 (obsolete) — Splinter Review
This whacks one more mole on the head. We really need a separate cache of these things on the window's C++ object so that we can share them between compartments with appropriate wrapping.
Assignee: general → mrbkap
Status: NEW → ASSIGNED
Attachment #499196 - Flags: review?(jst)
We need to fix this compartment mismatch before we ship.
blocking2.0: --- → betaN+
Keywords: regression
Attachment #499196 - Flags: review?(jst) → review+
Summary: "Assertion failure: compartment mismatched" with uneval(InstallTrigger) → [ready to land] "Assertion failure: compartment mismatched" with uneval(InstallTrigger)
Whiteboard: hardblocker
I built with the attached patch and I still get an assertion. Can you give this another look?
Assignee: mrbkap → gal
Component: JavaScript Engine → XPConnect
QA Contact: general → xpconnect
Summary: [ready to land] "Assertion failure: compartment mismatched" with uneval(InstallTrigger) → "Assertion failure: compartment mismatched" with uneval(InstallTrigger)
Attached patch patch, fixes both test cases (obsolete) — Splinter Review
Attachment #499196 - Attachment is obsolete: true
Attachment #501455 - Flags: review?(jst)
Attachment #501455 - Attachment is obsolete: true
Attachment #501456 - Flags: review?(jst)
Attachment #501455 - Flags: review?(jst)
Attachment #501456 - Flags: review?(jst) → review+
Whiteboard: hardblocker → hardblocker, fixed-in-tracemonkey
I backed this out because of tinderbox failures.
Whiteboard: hardblocker, fixed-in-tracemonkey → hardblocker
Whiteboard: hardblocker → hardblocker, fixed-in-tracemonkey
Fixed.

http://hg.mozilla.org/mozilla-central/rev/05cbcfe5d694
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.