The tabstrip should not support animated favicons

RESOLVED DUPLICATE of bug 111373

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 111373
8 years ago
5 years ago

People

(Reporter: faaborg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

This likely wasn't intentional on our part, but it looks like favicons in the tabstrip are allowed to animate.  This is super distracting, and doesn't really provide users with any value.

Example: http://news.softpedia.com/

Comment 1

8 years ago
Another example: about:robots ;)

Not sure how to display a still frame of an animated image.
I know window.stop() stops the animation, but I haven't been able to decipher the content and docshell code to see how it does that. 
Would ignoring the animated favicon entirely be too aggressive?
See also Bug 111373 & Bug 605197.

Comment 3

8 years ago
How would Firefox know which frame to show the user?  On softpedia it seems the correct frame (first or last) would work to show the user the 'S' but what about on other sites where the animation might first show nothing and then end with the logo or vice verse.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 111373
You need to log in before you can comment on or make changes to this bug.