SQLite-related 100% cpu load bug

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: john.s.peterson, Unassigned)

Tracking

({hang})

1.9.2 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0E)

The sqlite thread occupies 99.94% of all included samples (see linked VS10 Profiler report in Additional Information) making the GUI (regular program use) nearly impossible.

I'm running Firefox with Firefox portable (portableapps.com/apps/internet/firefox_portable) if that makes a difference.

My addons are (all latest version):
Adblock Plus
Adobe Acrobat - Create PDF
Adobe DLM (powered by getPlus(R))
Flagfox
Google Toolbar for Firefox
Hide Menubar
Javascript Debugger
Microsoft .NET Framework Asssistant
Tab Mix Plus

Reproducible: Sometimes

Steps to Reproduce:
Altogether it has happened dozens of times. It happens fairly rarely. Once every couple of hours. It started around 3.6.10 or 3.6.11 perhaps. I can't remember, it may be before that too.

I don't remember exactly how it happens all the time. The last time it occurred as I pressed the back button.
Actual Results:  
Firefox locks up

Expected Results:  
Firefox doesn't lock up

The problem can't be reproduced. It's random and happens when you create a new tab or go back, and once in perhaps twenty or thirty times you do that.

So my hope is that my attached VS10 Profiler report can help you figure out what's wrong.

Since it occurs for me once every couple of hours, please tell me if you want any more information from debugging and I can get it for you. I know how to use the VS debugger and profiler so please ask me for more information if you think that would help.
(Reporter)

Updated

8 years ago
Keywords: hang
(Reporter)

Comment 1

8 years ago
Created attachment 498478 [details]
VS10 Profiler Report
(Reporter)

Comment 2

8 years ago
I'll know in a day if the Firefox portable loader was part of the problem. I'm running without the portable loader now. (I didn't know about the Profile Folder setting before, that's why I used firefox portable).
Component: General → Storage
Product: Firefox → Toolkit
QA Contact: general → storage
Version: unspecified → 1.9.2 Branch
I don't have a way to view the profile, so I'll have to ask for some stacks in the bug.  FWIW, this is the consumers fault; SQLite just does what it is asked.
(Reporter)

Comment 4

8 years ago
You mean some call stacks? I'll save some if the bug occurs again. The profiler report will however show the call path that is repeated over and over.
(Reporter)

Comment 5

8 years ago
I also agree that SQLite is probably not the problem. What I mean with SQLite-related is that the runaway calls that locks the program are to SQLite functions. I didn't investigate it further. I just saved a VS10 Profiler report and hoped that would show the source of the problem.
(Reporter)

Comment 6

8 years ago
The bug occurred again without having FirefoxPortable.exe running or anything related to Firefox Portable, so it's a legitimate Firefox bug.

The bug occurred while I was seemingly not using the GUI at all, just reading a page. Or possibly scrolling the page.

I attached firefox.exe in VS10 and paused five times and saved the call stack. I also saved a new Profiler report. I'm hoping this will help.

I also forgot to mention the plugins I use (all latest version):
Adobe Acrobat 10.0.0.396
getPlusPlus for Adobe 16291	1.6.2.91
Google Update 1.2.183.39
Microsoft Office 2010 14.0.4730.1010
Microsoft Office 2010 14.0.4730.1010 (Office Authorization plug-in for NPAPI browsers)
Mozilla Default Plugin 1.0.0.15
Shockwave Flash	10.1.102.64
Silverlight Plug-In 4.0.50917.0

I can also list the versions of my extensions:
Adblock Plus 1.3.2
Adobe Acrobat - Create PDF 1.0
Adobe DLM (powered by getPlus(R)) 1.6.2.91
Flagfox 4.0.11
Google Toolbar for Firefox 7.1.20100830W
Hide Menubar 4.0.20101120
Javascript Debugger 0.9.88.1
Microsoft .NET Framework Asssistant 1.2.1
Tab Mix Plus 0.3.8.4

Themes:
Default 3.6.13

I'll be trying Firefox 4.0 from now on, with the same Profile Folder, to see if the bug is still present there.
(Reporter)

Comment 7

8 years ago
Created attachment 498549 [details]
New profiler report

it seems to show the same thing as the last profiler report. but i add it just in case. since the bug occurs so infrequently i can as well save a new profiler report.
(Reporter)

Comment 8

8 years ago
Created attachment 498550 [details]
VS10 Call stack, from pausing five times, randomly
This is Places:
>	sqlite3.dll!sqlite3VdbeExec(Vdbe * p)  Line 60481	C
 	sqlite3.dll!sqlite3Step(Vdbe * p)  Line 57936 + 0x7 bytes	C
 	sqlite3.dll!sqlite3_step(sqlite3_stmt * pStmt)  Line 58002 + 0x7 bytes	C
 	xul.dll!mozilla::storage::Statement::ExecuteStep(int * _moreResults)  Line 741	C++
 	xul.dll!nsNavHistory::ResultsAsList(mozIStorageStatement * statement, nsNavHistoryQueryOptions * aOptions, nsCOMArray<nsNavHistoryResultNode> * aResults)  Line 6332 + 0x1a bytes	C++
 	xul.dll!nsNavHistory::GetQueryResults(nsNavHistoryQueryResultNode * aResultNode, const nsCOMArray<nsNavHistoryQuery> & aQueries, nsNavHistoryQueryOptions * aOptions, nsCOMArray<nsNavHistoryResultNode> * aResults)  Line 4183 + 0xe bytes	C++
 	xul.dll!nsNavHistoryQueryResultNode::FillChildren()  Line 2482	C++
 	xul.dll!nsNavHistoryQueryResultNode::OpenContainer()  Line 2265	C++
 	xul.dll!nsNavHistoryContainerResultNode::SetContainerOpen(int aContainerOpen)  Line 560	C++
Component: Storage → Places
QA Contact: storage → places
(although, it could be generated by an add-on)
this could be related with bug 595530 or bug 556068, so navigating with the Library open on history. For sure here a view that is related to history is open and we don't left any open if they are not visible. Either there is a history view visible or a add-on has one.
(Reporter)

Comment 12

8 years ago
Created attachment 499656 [details]
VS10 Profiler report for 4.0b8
(Reporter)

Comment 13

8 years ago
Created attachment 499657 [details]
VS10 Call stack for 4.0b8, from pausing a few times randomly
(Reporter)

Comment 14

8 years ago
I posted a new call stack and profiler report for 4.0b8. This time the bug seems to have been triggered when I opened a new tab.



  Application Basics

        Name
        Firefox

        Version
        4.0b8

        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        Microsoft .NET Framework Assistant
        1.2.1
        false
        {20a82645-c095-46ed-80e3-08825760534b}

        JavaScript Debugger
        0.9.88.1
        false
        {f13b157f-b174-47e7-a34d-4815ddfdfeb8}

        Adobe Acrobat - Create PDF
        1.0
        false
        web2pdfextension@web2pdf.adobedotcom

        Google Toolbar for Firefox
        7.1.20101113Wb1
        true
        {3112ca9c-de6d-4884-a869-9855de68056c}

        Flagfox
        4.1a4
        true
        {1018e4d6-728f-4b20-ad56-37578a4de76b}

        Tab Mix Plus
        0.3.8.5pre.101112a
        true
        {dc572301-7619-498c-a57d-39143191b318}

        Adblock Plus
        1.3.3
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Feedback
        1.0.3
        false
        testpilot@labs.mozilla.com

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.fixup.alternate.enabled
        false

        browser.history_expire_days.mirror
        180

        browser.places.importBookmarksHTML
        false

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20101214170338

        browser.startup.homepage_override.mstone
        rv:2.0b8

        browser.tabs.warnOnClose
        false

        dom.disable_window_move_resize
        true

        extensions.checkCompatibility.4.0b
        false

        extensions.lastAppVersion
        4.0b8

        general.useragent.extra.microsoftdotnet
        ( .NET CLR 3.5.30729; .NET4.0E)

        keyword.URL
        http://www.google.com/search?sourceid=navclient&hl=en&q=

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        257670

        places.last_vacuum
        1291860415

        print.print_printer
        Adobe PDF

        print.printer_Adobe_PDF.print_bgcolor
        false

        print.printer_Adobe_PDF.print_bgimages
        false

        print.printer_Adobe_PDF.print_command

        print.printer_Adobe_PDF.print_downloadfonts
        false

        print.printer_Adobe_PDF.print_edge_bottom
        0

        print.printer_Adobe_PDF.print_edge_left
        0

        print.printer_Adobe_PDF.print_edge_right
        0

        print.printer_Adobe_PDF.print_edge_top
        0

        print.printer_Adobe_PDF.print_evenpages
        true

        print.printer_Adobe_PDF.print_footercenter

        print.printer_Adobe_PDF.print_footerleft
        &PT

        print.printer_Adobe_PDF.print_footerright
        &D

        print.printer_Adobe_PDF.print_headercenter

        print.printer_Adobe_PDF.print_headerleft
        &T

        print.printer_Adobe_PDF.print_headerright
        &U

        print.printer_Adobe_PDF.print_in_color
        true

        print.printer_Adobe_PDF.print_margin_bottom
        0.5

        print.printer_Adobe_PDF.print_margin_left
        0.5

        print.printer_Adobe_PDF.print_margin_right
        0.5

        print.printer_Adobe_PDF.print_margin_top
        0.5

        print.printer_Adobe_PDF.print_oddpages
        true

        print.printer_Adobe_PDF.print_orientation
        0

        print.printer_Adobe_PDF.print_pagedelay
        500

        print.printer_Adobe_PDF.print_paper_data
        1

        print.printer_Adobe_PDF.print_paper_height
        11,00

        print.printer_Adobe_PDF.print_paper_size_type
        0

        print.printer_Adobe_PDF.print_paper_size_unit
        0

        print.printer_Adobe_PDF.print_paper_width
        8,50

        print.printer_Adobe_PDF.print_reversed
        false

        print.printer_Adobe_PDF.print_scaling
        1,00

        print.printer_Adobe_PDF.print_shrink_to_fit
        true

        print.printer_Adobe_PDF.print_to_file
        false

        print.printer_Adobe_PDF.print_unwriteable_margin_bottom
        0

        print.printer_Adobe_PDF.print_unwriteable_margin_left
        0

        print.printer_Adobe_PDF.print_unwriteable_margin_right
        0

        print.printer_Adobe_PDF.print_unwriteable_margin_top
        0

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        AMD Radeon HD 6800 Series

        Vendor ID
        1002

        Device ID
        6738

        Adapter RAM
        1024

        Adapter Drivers
        aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.782.0.0

        Driver Date
        9-28-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true

      GPU Accelerated Windows
      1/1 Direct3D 10

Enabled plugins
Find more information about browser plugins at mozilla.org.
Find updates for installed plugins at mozilla.com/plugincheck.
Help for installing plugins is available from plugindoc.mozdev.org.
Shockwave Flash

    File: NPSWF32.dll
    Version: 10.1.102.64
    Shockwave Flash 10.1 r102

MIME Type 	Description 	Suffixes
application/x-shockwave-flash 	Adobe Flash movie 	swf
application/futuresplash 	FutureSplash movie 	spl
Silverlight Plug-In

    File: npctrl.dll
    Version: 4.0.51204.0
    4.0.51204.0

MIME Type 	Description 	Suffixes
application/x-silverlight 	npctrl 	scr
application/x-silverlight-2 		
Microsoft Office 2010

    File: NPAUTHZ.DLL
    Version: 14.0.4730.1010
    Office Authorization plug-in for NPAPI browsers

MIME Type 	Description 	Suffixes
application/x-msoffice14 	14.0.4730.1010 	*
Microsoft Office 2010

    File: NPSPWRAP.DLL
    Version: 14.0.4730.1010
    The plug-in allows you to open and edit files using Microsoft Office applications

MIME Type 	Description 	Suffixes
application/x-sharepoint 	SharePoint Plug-in for Firefox 	
getPlusPlus for Adobe 16291

    File: np_gp.dll
    Version: 1.6.2.91
    getplusplusadobe16291

MIME Type 	Description 	Suffixes
application/getplusplusadobe16291 	getplusplusadobe16291 	
Google Update

    File: npGoogleOneClick8.dll
    Version: 1.2.183.39
    Google Update

MIME Type 	Description 	Suffixes
application/x-vnd.google.oneclickctrl.8 		
Adobe Acrobat

    File: nppdf32.dll
    Version: 10.0.0.396
    Adobe PDF Plug-In For Firefox and Netscape 10.0.0

MIME Type 	Description 	Suffixes
application/pdf 	Acrobat Portable Document Format 	pdf
application/vnd.adobe.pdfxml 	Adobe PDF in XML Format 	pdfxml
application/vnd.adobe.x-mars 	Adobe PDF in XML Format 	mars
application/vnd.fdf 	Acrobat Forms Data Format 	fdf
application/vnd.adobe.xfdf 	XML Version of Acrobat Forms Data Format 	xfdf
application/vnd.adobe.xdp+xml 	Acrobat XML Data Package 	xdp
application/vnd.adobe.xfd+xml 	Adobe FormFlow99 Data File 	xfd
(Reporter)

Comment 15

8 years ago
This bug may have been fixed in 5.0, I haven't had it freeze since I started using it at least two weeks ago.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.