Provide a menuitem/button/shortcut key for New Group

RESOLVED WONTFIX

Status

Firefox Graveyard
Panorama
P5
normal
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: ithinc, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101217 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101217 Firefox/4.0b9pre

There is a lack of menuitem/button/shortcut key for New Group?

Reproducible: Always
(Reporter)

Updated

8 years ago
Component: General → TabCandy
Version: unspecified → Trunk
QA Contact: general → tabcandy

Comment 1

8 years ago
You can currently create a new group by either clicking or dragging in a blank space, place two tabs on top of each other, and (shortly) by double-clicking in empty space.

Given that you have to specify a physical location for a new group, I wouldn't want an action that didn't inherently have a location on-screen (menu button, hot key) to create a new group.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> You can currently create a new group by either clicking or dragging in a blank
> space, place two tabs on top of each other, and (shortly) by double-clicking in
> empty space.
> 
> Given that you have to specify a physical location for a new group, I wouldn't
> want an action that didn't inherently have a location on-screen (menu button,
> hot key) to create a new group.

I don't quite understand what you're saying. People may like a New Group command in the main Firefox UI, without showing Panorama.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 3

8 years ago
Ah, you would like a command (button, key, or menu) that you can hit from the tabbed browser that would create a new group with fresh tab in it? 

I can dig that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
Target Milestone: --- → Future
(In reply to comment #1)
> Given that you have to specify a physical location for a new group, I wouldn't
> want an action that didn't inherently have a location on-screen (menu button,
> hot key) to create a new group.

For this point, such UI would require bug 592932.
Depends on: 592932
(Reporter)

Comment 5

8 years ago
At this point, I can implement it with:
TabView._initFrame(function() {
  var tab = gBrowser.addTab();
  TabView.moveTabTo(tab, null);
  gBrowser.selectedTab = tab;
});

So bug 592932 may not necessarily block this.
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 8 years ago2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.