Closed Bug 620099 Opened 9 years ago Closed 9 years ago

Crash [@ js::GetFlatUpvar(JSContext*, JSObject*, int, js::Value*) ] [@ js::GetFlatUpvar ]

Categories

(Core :: JavaScript Engine, defect, critical)

x86
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 592202
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: jk1700, Unassigned)

References

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101217 Firefox/4.0b9pre
Build Identifier: 

http://crash-stats.mozilla.com/report/index/bp-5b521399-2853-4e13-b2ca-c011f2101217

This crash happend to me few times when saving comment in bugzilla.mozilla, but I don't have reliable STR

Reproducible: Always
This bug should have set dependency to bug 592202 as per bug 616762 comment 18, but I don't access to bug 592202
Keywords: crash
See Also: → 616762
It is #8 top crasher in 4.0b9pre for the last 3 days.

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=js%3A%3AGetFlatUpvar%28JSContext*%2C%20JSObject*%2C%20int%2C%20js%3A%3AValue*%29
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
OS: Windows 7 → All
Summary: Crash [@ js::GetFlatUpvar(JSContext*, JSObject*, int, js::Value*) ] → Crash [@ js::GetFlatUpvar(JSContext*, JSObject*, int, js::Value*) ] [@ js::GetFlatUpvar ]
Version: unspecified → Trunk
blocking2.0: ? → betaN+
Depends on: 592202
Is this not a dupe of bug 618558?
In Safe Mode, did not seem to crash. Disabled all add-ons and plugins, cleaned the old month in the journal, has not helped. There is a very large number starnits. On this constantly https: / / bugzilla.mozilla.org / show_bug.cgi? Id = 620364 on many other current and where to send this comment, when you click on any of the pages have to add to chromium. Just noticeable permanent freeze the browser loads the cpu 50-60% of the time.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592202
No longer depends on: 592202
You are not authorized to access bug #592202.
Seeing as I'm not a member of the Security Working Group, I can't access bug 592202. FWIW, here's another breakpad report: bp-b84d8749-c825-46da-a009-45e0f2110104
Problem solved, but still do not understand how. Maybe blame firebug.
Problems with language in a larger case no. Problems with:
Mathematics and stsientses
Nicer typography in plain text Phils
Combining charatsters
Thai (UCS Level 2)
Box drawing alignment
Sorry, last comment did not write back.
adminnu: yes, some bugs are private. eventually the bug will not be private. in the interim, you'll have to wait. and yes, a quick skim of the other bug indicates that the debugger code enables the engine to violate an internal (slightly bogus?) constraint. the bug in question is actually close to being fixed.

alan: sorry, why do you think that's useful? the bug is a resolved duplicate. you're just adding a comment which in theory someone might have to read and then discard. we only need stacks when we don't understand the problem, in resolved bugs we typically *do* understand the problem.
Thank you for your reply. I just can not now experimenting. But most likely helped to reinstall firebug, off to no avail. Perhaps this filter can you find the true cause.
as i already noted, this bug is close to being fixed. if we needed more information, we'd ask for it. we aren't.

we request patience instead.
Crash Signature: [@ js::GetFlatUpvar(JSContext*, JSObject*, int, js::Value*) ] [@ js::GetFlatUpvar ]
You need to log in before you can comment on or make changes to this bug.