crash [@ gfxContext::Translate ]

RESOLVED DUPLICATE of bug 609049

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 609049
7 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression, topcrash})

Trunk
x86
Mac OS X
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(crash signature)

(Reporter)

Description

7 years ago
It is a new crash signature that appeared in 4.0b8pre/20101217.
It is #35 top crasher in this build.

Signature	gfxContext::Translate
UUID	4386248e-a7fd-4963-9438-195b52101217
Time 	2010-12-17 19:34:33.847619
Uptime	315
Last Crash	350 seconds (5.8 minutes) before submission
Install Age	22692 seconds (6.3 hours) since version was first installed.
Product	Firefox
Version	4.0b9pre
Build ID	20101217030324
Branch	2.0
OS	Mac OS X
OS Version	10.5.8 9L31a
CPU	x86
CPU Info	family 6 model 15 stepping 11
Crash Reason	EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE
Crash Address	0x4
User Comments	Watching a video on Hulu, crashed as soon as I hit escape to exit full screen mode. Second time this has happened.
App Notes 	Renderers: 0x24200,0x20400

Frame 	Module 	Signature [Expand] 	Source
0 	XUL 	gfxContext::Translate 	gfx/thebes/gfxContext.cpp:278
1 	XUL 	mozilla::layers::BasicBufferOGL::BeginPaint 	gfx/layers/opengl/ThebesLayerOGL.cpp:463
2 	XUL 	mozilla::layers::ThebesLayerOGL::RenderLayer 	gfx/layers/opengl/ThebesLayerOGL.cpp:546
3 	XUL 	mozilla::layers::ContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:236
4 	XUL 	mozilla::layers::ContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:236
5 	XUL 	mozilla::layers::LayerManagerOGL::Render 	gfx/layers/opengl/LayerManagerOGL.cpp:600
6 	XUL 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:418
7 	XUL 	nsDisplayList::PaintForFrame 	layout/base/nsDisplayList.cpp:477
8 	XUL 	nsDisplayList::PaintRoot 	layout/base/nsDisplayList.cpp:384
9 	XUL 	nsLayoutUtils::PaintFrame 	layout/base/nsLayoutUtils.cpp:1433
10 	XUL 	PresShell::Paint 	layout/base/nsPresShell.cpp:6093
11 	XUL 	nsViewManager::RenderViews 	view/src/nsViewManager.cpp:447
12 	XUL 	nsViewManager::Refresh 	view/src/nsViewManager.cpp:413
13 	XUL 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:912
14 	XUL 	HandleEvent 	view/src/nsView.cpp:161
15 	XUL 	nsChildView::DispatchEvent 	widget/src/cocoa/nsChildView.mm:1786
16 	XUL 	nsChildView::DispatchWindowEvent 	widget/src/cocoa/nsChildView.mm:1796
17 	XUL 	-[ChildView drawRect:inContext:] 	widget/src/cocoa/nsChildView.mm:2728
18 	XUL 	-[ChildView drawRect:] 	widget/src/cocoa/nsChildView.mm:2632
19 	AppKit 	-[NSView _drawRect:clip:] 	
20 	AppKit 	-[NSView _recursiveDisplayAllDirtyWithLockFocus:visRect:] 	
21 	AppKit 	-[NSView _recursiveDisplayAllDirtyWithLockFocus:visRect:] 	
22 	AppKit 	-[NSView _recursiveDisplayAllDirtyWithLockFocus:visRect:] 	
23 	AppKit 	-[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] 	
24 	AppKit 	-[NSThemeFrame _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] 	
25 	AppKit 	-[NSView _displayRectIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:] 	
26 	AppKit 	-[NSView displayIfNeeded] 	
27 	AppKit 	-[NSWindow displayIfNeeded] 	
28 	AppKit 	_handleWindowNeedsDisplay 	
29 	CoreFoundation 	__CFRunLoopDoObservers 	
30 	CoreFoundation 	CFRunLoopRunSpecific 	
31 	CoreFoundation 	CFRunLoopRunInMode 	
32 	HIToolbox 	RunCurrentEventLoopInMode 	
33 	HIToolbox 	ReceiveNextEventCommon 	
34 	HIToolbox 	BlockUntilNextEventMatchingListInMode 	
35 	AppKit 	_DPSNextEvent 	
36 	AppKit 	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	
37 	AppKit 	-[NSApplication run] 	
38 	XUL 	nsAppShell::Run 	widget/src/cocoa/nsAppShell.mm:746
39 	XUL 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:191
40 	XUL 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3691
41 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:158
42 	firefox-bin 	firefox-bin@0xa05 	
43 		@0x1 	

The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a5413c3c1013&tochange=d1da1005b6d6

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=gfxContext%3A%3ATranslate
(Reporter)

Comment 1

7 years ago
It is #5 top crasher on Mac OS X in 4.0b9pre for the last week.
blocking2.0: --- → ?
Keywords: topcrash

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 609049
blocking2.0: ? → final+
(Assignee)

Updated

7 years ago
Crash Signature: [@ gfxContext::Translate ]
You need to log in before you can comment on or make changes to this bug.