Closed Bug 620159 Opened 9 years ago Closed 8 years ago

nsVorbisState::Time needs to handle failure from return from MulOverflow

Categories

(Core :: Audio/Video, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 601535

People

(Reporter: timeless, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: coverity)

374 PRInt64 nsVorbisState::Time(PRInt64 granulepos)
375 {
376   if (granulepos == -1 || !mActive || mDsp.vi->rate == 0) {
377     return -1;
378   }
379   PRInt64 t = 0;

I'm told this is multiplying a 10bit number by a 63bit number which can overflow a 64bit number
380   MulOverflow(1000, granulepos, t);
381   return t / mDsp.vi->rate;
382 }
This bug is fixed with Bug 601535.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 601535
You need to log in before you can comment on or make changes to this bug.