When FireFox starts, it's not loading last session tabs!

VERIFIED INCOMPLETE

Status

()

Firefox
Session Restore
VERIFIED INCOMPLETE
8 years ago
8 years ago

People

(Reporter: Sam Hussein, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-02-01])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

This issue seems to be recent,
My general settings have (When Firefox starts, Show my windows and tabs from last time).
Previous versions worked well, even when I had 80 tabs!
Now with only less than 10 tabs, Firefox frequently (daily) forgets these tabs and starts with one tab only, to my default home page.

I have rechecked the settings, and they are still as I described above.
This is getting very annoying, as I have to open the History, and start loading these tabs one by one.
It's not bad when you have a few tabs, but it becomes very ugly when the tabs are many!

It seems to me that this happens when some of the plugins or addons are automatically updated by Firefox.
 
I have Chrome 8 also, and I have loaded it with 95 tabs. It always restored the previous session, with all the tabs. Never missed even once!

Thank you.


Reproducible: Sometimes

Steps to Reproduce:
1. I think the answer is pretty obvious for this case. Just use a dozen or more tabs.
2. See text above regarding the plug-ins, add-on components
3.
Actual Results:  
N/A

Expected Results:  
N/A

Should've restored all my tabs from the last session!!!

Comment 1

8 years ago
If you have chosen to clear Firefox's browsing history when it closes, that overrides the "When Firefox starts, Show my windows and tabs from last time" setting.

Updated

8 years ago
Version: unspecified → 3.6 Branch
Please check to see if you have history set to clear on exit, per comment 1.

Also, to eliminate extensions being the cause, please try with a clean profile:
http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_make-a-new-profile
Whiteboard: [closeme 2011-02-01]
Whiteboard closeme date been and gone, so marking as incomplete.

Please comment on/reopen this issue if it still occurs after following the advice in the previous comment - thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

8 years ago
(In reply to comment #1  @Mardeg)
> If you have chosen to clear Firefox's browsing history when it closes, that
> overrides the "When Firefox starts, Show my windows and tabs from last time"
> setting.

In my description, I said that I have had to reload my tabs one by one from the history. Please read it again.
This should tell you that history was not touched.
By the way, I am not a novice.
I have gone back to Firefox 3.xx.xx, but even 3.x crashes often, and I do have the error reporting turned on.
It crashed twice today alone, with only 3 or 4 tabs open (one of today's crashes was when I clicked to play a video on YouTube).
_____________________________
Status: RESOLVED → VERIFIED
(Reporter)

Updated

8 years ago
Severity: major → normal
Regardless of that, there was still no response to comment 2's suggestion of trying a new profile, which is why this was marked as incomplete.

Please reopen after trying that.
(Reporter)

Comment 6

8 years ago
Thank you Rd.
I have given up, and decided to use a different browser, and it has been running for quite sometime now (several weeks) without a single problem or a crash, with 65 tabs open, while FF crashes on a daily basis.
Of course the "different" browser is not IE.

You may re-open this issue if you'd like to, but I am closing it.
Thanks again.
__________________________________________
Status: VERIFIED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: INCOMPLETE → FIXED

Updated

8 years ago
Resolution: FIXED → INCOMPLETE
Fixed is not the correct resolution for this issue, changing back to
incomplete.

If you decide to use Firefox again in the future, I'd recommend trying a clean
profile, since that will likely solve all problems, including crashing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.