Thunderbird hang when getting, downloading mail. Caused by SPAMfighter

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: Jeff Berger, Unassigned)

Tracking

({64bit, hang, stackwanted})

x86_64
Windows 7
64bit, hang, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs stack][add-on: SPAMfighter], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.224 Safari/534.10
Build Identifier: Thunderbird 3.1.7

I have TB 3.1.7 and have had this problem continuously for the last three MONTHS. Usually when downloading mail, the program hangs and the only way to get anything accomplished is to shut it down (or wait 20 minutes for it to resolve itself, which usually does not happen). I have a large install (business use, sole proprietorship) and moved a lot into archives since I was told that would fix this problem. It has not. HELP!

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird
2. Download mail
3. Crash (hang); then says Not Responding and stays that way
Actual Results:  
See above

Expected Results:  
I should have been able to work
(Reporter)

Comment 1

8 years ago
Be happy to have someone look at this install remotely. This is driving me nuts. I am dealing with cancer...and THIS is a worse problem than that.
Keywords: 64bit, crash
Version: unspecified → 3.1

Comment 2

8 years ago
please post the crash report ID
https://support.mozillamessaging.com/en-US/kb/Thunderbird+crashes
(Reporter)

Comment 3

8 years ago
What is that & where do I find it?
(Reporter)

Comment 4

8 years ago
I've apparently found the cause of this and it should be something you can fix easily. Some time ago, to stop interruptions from incoming email, I -- in Tools / Account Settings -- Server Settings -- unchecked Automatically Download, but left both "check" items checked. When I wanted email I clicked Get Mail and got many crashes instead. Since I went back in and checked "Automatically download" the problem has stopped. Either that is a bug...or it is a feature...in which case you cannot allow people to do what I did because it consistently crashes the program during downloads. This was a harrowing problem over nearly four months....
(In reply to comment #3)
> What is that & where do I find it?

Ho nice we know how to reproduce, could you follow instructions in comment 2 and give us a crashID please ?
(Reporter)

Comment 6

8 years ago
*****NOT FIXED****** 

--- crashed another two times yesterday afternoon, again overnight, and again a little a while ago. Sending dump.
(Reporter)

Comment 7

8 years ago
OK, where is the dump file? I want to post it here but don't see anything... will look in Profiles.
(Reporter)

Comment 8

8 years ago
Can not attach the dump file. I am getting all kinds of unintelligible requests from your system including description arguments and foo/bar. No clue what that all means. Happy to give you the file but I can't waste time deciphering these messages. I have work to do...
OS: Windows 7 → Windows XP
Why don't you just submit them when the crash reporter shows up ?
(Reporter)

Comment 10

8 years ago
The crash reporter does not show up. The program hangs interminably and I have to go to Task Manager to kill it.
(Reporter)

Comment 11

8 years ago
When it works, it's fine... but it is crashing several times a day...

Comment 12

8 years ago
hang ^=> crash

stacktrace wanted for hang
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
Keywords: crash → hang, stackwanted
Summary: Thunderbird crashes when downloading mail. → Thunderbird hang when downloading mail.
(Reporter)

Comment 13

8 years ago
I will do that. Has crashed three times this morning. I am getting mail off an ISP web interface....TB is beyond unreliable. Noticed above that my OS was listed incorrectly. It is Windows 7 64-bit upgraded a year ago from Vista.
OS: Windows XP → Windows 7
(Reporter)

Comment 14

8 years ago
This is what I get -- tried it four times. First time nothing reloaded; second and third times, never got *busy*. Fourth time got this...  Here you go: [I will be back; must go to meeting.] 

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

CommandLine: "C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe"
Symbol search path is: *** Invalid ***
****************************************************************************
* Symbol loading may be unreliable without a symbol search path.           *
* Use .symfix to have the debugger choose a symbol path.                   *
* After setting your symbol path, use .reload to refresh symbol locations. *
****************************************************************************
Executable search path is: 
ModLoad: 00000000`00c70000 00000000`0188c000   thunderbird.exe
ModLoad: 00000000`77460000 00000000`7760b000   ntdll.dll
ModLoad: 00000000`77640000 00000000`777c0000   ntdll32.dll
ModLoad: 00000000`73c50000 00000000`73c8f000   C:\Windows\SYSTEM32\wow64.dll
ModLoad: 00000000`73bf0000 00000000`73c4c000   C:\Windows\SYSTEM32\wow64win.dll
ModLoad: 00000000`73be0000 00000000`73be8000   C:\Windows\SYSTEM32\wow64cpu.dll
(2244.1454): Break instruction exception - code 80000003 (first chance)
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll.dll - 
ntdll!CsrSetPriorityClass+0x40:
00000000`77511340 cc              int     3
0:000> sympath SRV*c:\symbols*http://symbols.mozilla.org/thunderbird;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for thunderbird.exe - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\SYSTEM32\wow64cpu.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\SYSTEM32\wow64win.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\SYSTEM32\wow64.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll32.dll - 
Couldn't resolve error at 'ympath SRV*c:\symbols*http://symbols.mozilla.org/thunderbird;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols'
0:000> symfix+ c:\symbols
Couldn't resolve error at 'ymfix+ c:\symbols'
0:000> .reload /f
*********************************************************************
* Symbols can not be loaded because symbol path is not initialized. *
*                                                                   *
* The Symbol Path can be set by:                                    *
*   using the _NT_SYMBOL_PATH environment variable.                 *
*   using the -y <symbol_path> argument when starting the debugger. *
*   using .sympath and .sympath+                                    *
*********************************************************************
Create c:\symbols and make it writable by anybody (using the porperty tab on the folderr) and start again :D
(Reporter)

Comment 16

8 years ago
The folder already exists and contains thunderbird.pdb among other files. I try to unset Read Only on the folder and click Apply, but when I shut down the directory and restart it...it is still showing read only. ???  (I am a marketing writer, not a software writer... ;)

Comment 17

8 years ago
suggest you create the directory in %appdata% and adjust the steps in instruction accordingly
(Reporter)

Comment 18

8 years ago
Done. Still getting lots of errors:

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

CommandLine: "C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe"
Symbol search path is: c:\Users\jmbcomms\AppData\symbols
Executable search path is: 
ModLoad: 00000000`00310000 00000000`00f2c000   thunderbird.exe
ModLoad: 00000000`77460000 00000000`7760b000   ntdll.dll
ModLoad: 00000000`77640000 00000000`777c0000   ntdll32.dll
ModLoad: 00000000`73c50000 00000000`73c8f000   C:\Windows\SYSTEM32\wow64.dll
ModLoad: 00000000`73bf0000 00000000`73c4c000   C:\Windows\SYSTEM32\wow64win.dll
ModLoad: 00000000`73be0000 00000000`73be8000   C:\Windows\SYSTEM32\wow64cpu.dll
(1ef8.d74): Break instruction exception - code 80000003 (first chance)
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll.dll - 
ntdll!CsrSetPriorityClass+0x40:
00000000`77511340 cc              int     3
0:000> sympath SRV*c:\symbols*http://symbols.mozilla.org/thunderbird;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for thunderbird.exe - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\SYSTEM32\wow64cpu.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\SYSTEM32\wow64win.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\SYSTEM32\wow64.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll32.dll - 
Couldn't resolve error at 'ympath SRV*c:\symbols*http://symbols.mozilla.org/thunderbird;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols'
0:000> symfix+ c:\Users\jmbcomms\AppData\symbols
Couldn't resolve error at 'ymfix+ c:\Users\jmbcomms\AppData\symbols'
0:000> reload /f
            ^ Bad register error in 'reload /f'
(In reply to comment #18)
> Done. Still getting lots of errors:
> 
> Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
> Copyright (c) Microsoft Corporation. All rights reserved.
> 
> CommandLine: "C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe"
> Symbol search path is: c:\Users\jmbcomms\AppData\symbols
> Executable search path is: 
> ModLoad: 00000000`00310000 00000000`00f2c000   thunderbird.exe
> ModLoad: 00000000`77460000 00000000`7760b000   ntdll.dll
> ModLoad: 00000000`77640000 00000000`777c0000   ntdll32.dll
> ModLoad: 00000000`73c50000 00000000`73c8f000   C:\Windows\SYSTEM32\wow64.dll
> ModLoad: 00000000`73bf0000 00000000`73c4c000   C:\Windows\SYSTEM32\wow64win.dll
> ModLoad: 00000000`73be0000 00000000`73be8000   C:\Windows\SYSTEM32\wow64cpu.dll
> (1ef8.d74): Break instruction exception - code 80000003 (first chance)
> *** ERROR: Symbol file could not be found.  Defaulted to export symbols for
> ntdll.dll - 
> ntdll!CsrSetPriorityClass+0x40:
> 00000000`77511340 cc              int     3
> 0:000> sympath
> SRV*c:\symbols*http://symbols.mozilla.org/thunderbird;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols

[snip]

> Couldn't resolve error at 'ympath
> SRV*c:\symbols*http://symbols.mozilla.org/thunderbird;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols'

Why is this still c:\symbols ?
(Reporter)

Comment 20

8 years ago
I don't know. You can see the symbol search path is changed (above, same output.)

Comment 21

8 years ago
the command is ".sympath", the <dot> at the beginning is *critical*.

similarly, it's ".reload"

Please use copy and paste, please do *not* try to manually type commands.

Comment 22

7 years ago
in addition to cmoment 21, if you are imap please obtain a log of 
  timestamp,imap:5,autosync:5
per https://wiki.mozilla.org/MailNews:Logging
Summary: Thunderbird hang when downloading mail. → Thunderbird hang when getting, downloading mail.
Whiteboard: [closeme 2011-03-15][needs stack]
(Reporter)

Comment 23

7 years ago
I have no idea what you are asking. This problem occurs both on my desktop, which I am now using, and on my laptop, which I used over the last seven weeks while on a long business trip. It is much worse on the desktop, almost to the point of being unusable. Please tell me in plain English exactly what you want and how I get it and I will pull it for you. Thank you. Obviously I'd like to solve this, it has dragged on for many months and I don't have time to play games here.
(Reporter)

Comment 24

7 years ago
If somebody out there wants to use team viewer to take control and get these reports, fine; this is infuriating and I do not have time to waste here...

Comment 25

7 years ago
Jeff, thanks for hanging in there. If you adjust per comment 21 you can probably get what is needed.

And, to simultaneously approach this from a different angle:

1. do you have filters defined that take messages from your inbox to other folders? And if so, if you temporarily rename msgFilterRules.dat to XmsgFilterRules.dat while thunderbird is down, does the problem go away?

2. you said "checked "Automatically download" the problem has stopped." ... so is it true this only happens if you do a MANUAL check for new mail?  And does it happen when you do "Get New Messages" even when "automatic" is enabled?

3. does crash go away if you disable "sync" (uncheck Keep Messages at Tools > Accounts > Sync and Storage) or global search (uncheck Global Search at Tools > Options > Advanced > General) ?


> I ... moved a lot into archives since I was told that would fix this problem. It has not. HELP!

that action needed to be done anyway, and irrc was in context with  Bug 598662, not this new bug.  Can we close Bug 598662 as being caused by Norton?
Whiteboard: [closeme 2011-03-15][needs stack] → [needs stack]
(Reporter)

Comment 26

7 years ago
And, to simultaneously approach this from a different angle:

1. do you have filters defined that take messages from your inbox to other
folders? And if so, if you temporarily rename msgFilterRules.dat to
XmsgFilterRules.dat while thunderbird is down, does the problem go away?

===Will do this. Tried unchecking all filters but that failed to stop the crashes. Am also getting crashes now where the program freezes altogether when writing mail replies.

2. you said "checked "Automatically download" the problem has stopped." ... so
is it true this only happens if you do a MANUAL check for new mail?  And does
it happen when you do "Get New Messages" even when "automatic" is enabled?

=====It is spastic. Happens sometimes when I am not at the computer...sometimes when I try to download manually with automatic checked [it does not automatically download mail on startup even though it is "checked" to do so] and when I click Get Mail it often starts to download and hangs during the process without finishing. Oddly, if I go to a web mail interface and cull out junk, then restart TBird, it usually downloads without a hitch...

3. does crash go away if you disable "sync" (uncheck Keep Messages at Tools >
Accounts > Sync and Storage) or global search (uncheck Global Search at Tools >
Options > Advanced > General) ?
=== I do not find "Sync and Storage". I get to Tools and Account Settings -- I don't have "Accounts". I DID just do the latter re: disable Windows search.

Comment 27

7 years ago
(In reply to comment #26)
> 3. does crash go away if you disable "sync" (uncheck "Keep Messages" at Tools >
> Accounts > Sync and Storage) ... ?
> === I do not find "Sync and Storage". I get to Tools and Account Settings -- I
> don't have "Accounts". I DID just do the latter re: disable Windows search.

Tools > accounts > (account name) > Synchronize and Storage


at Tools > accounts > (account name) > Server 
the first line at the top of the window shows the Server Type
(Reporter)

Comment 28

7 years ago
I have nothing under Account Name / Server Settings that says "Synchronize and Storage." I also have not found msgFilterRules.dat in the software files; where exactly is it? I looked in the program software and under App Data, where the Roaming files are, and found it in neither place. FYI I did disable Windows Search. Program seemed a bit more stable (lasted an hour), now has crashed three times since...

Comment 29

7 years ago
NO!  :)
Account Name / Server Settings  is where you get server type (pop or imap) and settings
Account Name / Synchronize and Storage   is where you find sync settings

http://lmgtfy.com/?q=msgFilterRules.dat
msgFilterRules.dat are found in %appdata%\imapmail\(account name)


rereading comment 0, if you have to wait 20 minutes, sounds like a protocol or firewall issues.  What type of account - pop or imap? And what firewall and antivirus software do you run?
(Reporter)

Comment 30

7 years ago
I think -- at long last -- I know what has been going on here. I have been using SpamFighter Pro on my systems for about two years. The problem started simultaneously on both systems in mid-Summer. It happens only when downloading mail -- the one time when SpamFighter is doing its thing. Trying a myriad of other suggested TBird solutions has yielded no cure, so I filed a report with SpamFighter. They said to uninstall the program and see what happens. I did; for 24 hours Thunderbird performed flawlessly, as it never has for the past six months. Then I got an email from SpamFighter Support reading:

I have a new version of SPAMfighter, which will most likely solve the problem. 
Please reinstall SPAMfighter from here:

http://download.spamfighter.com/spamfighter/client/5/SPAMfighter_Client_7.2.46Full.exe

That version differs from the standard download. I have been using it all day and so far, Thunderbird is still flawless. I am still treading lightly... I want to put back Windows Search (now off) and automatic mail downloads (also off), but right now it looks like the problem was a disconnect between TBird and SpamFighter... something for you to be aware of since there are so many users of both. Thanks for all your help here. -Jeff

Comment 31

7 years ago
Jeff, thanks for the update.

Here are some of the other hangs from spamfighter

bug 552331 - Fails to close completely if Window close x top right is pressed
bug 605828 - Can't send email. Pressing "Send" button does nothing. caused by SPAMfighter
bug 621388 - Send button not running anymore caused by SPAMfighter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Summary: Thunderbird hang when getting, downloading mail. → Thunderbird hang when getting, downloading mail. Caused by SPAMfighter
Whiteboard: [needs stack] → [needs stack][add-on: SPAMfighter]

Updated

7 years ago
Duplicate of this bug: 598662
You need to log in before you can comment on or make changes to this bug.